Solved: File Transfers To Target Machine Failing. Technical problems or part of the experience?

I’ve been going through some retired machines, and I’ve come across this problem with three or more. Currently working on nibbles. had the same problem with solid state.

It happens when I’ve gotten a user shell on the target and am working on privilege escalation. I use either a python http server or nc to transfer files, but the transfer hangs about half way through.

It eventually just ended up working for solid state, but I not because I tried anything new. It just worked eventually. I’m still spinning my tires with nibbles.

Is there something wrong with my tools or network, or is this a learning opportunity?


I have seen that happen before, it would usually stop at roughly the same spot, but only on certain machines.

If you are running a personal (non-HTB) VPN on your host machine, try disabling it right before you make the transfer.

Edit: I should add, this is assuming software like defender on the target isn’t to blame, of course.

Thanks @svenkali that fixed it! I disabled my personal VPN on my host/hypervisor and the transfer worked right away.

You’re welcome, glad you got it working.