NMAP all ports are in ignored state

Hi guys, I have a problem with Nmap.
When I scan:

nmap (different stuff like -sV -Pn) +ip

The scan complete with 1000 ports scanned but in ignored state(conn-refused).

I search on the web but nothing resolve this, do you know why? Or do you have a good alternative to nmap?
Thank you!

1 Like

It signifies that although Nmap was able to finish a TCP handshake with the target system, the target system actively refused the connection when Nmap states that a port is in the “closed” or “conn-refused” state. This could indicate that no service is listening on that port or that the target system’s firewall is preventing the connection.

Ports that are deliberately excluded from the scan using the “—exclude-ports” option or by the target system’s firewall preventing the connection are referred to as being in the “ignored” state in Nmap, which does not provide any information about the port’s status.

It’s likely that some of the ports Nmap lists as “ignored” are truly closed or filtered; however, Nmap was unable to ascertain their status because of the scan settings chosen or the target system’s network configuration.

You can experiment with various Nmap scan options and approaches, such as UDP scans or version detection (-sV) to identify certain services operating on the target system, to gain a deeper understanding of the target system’s network topology and services. To learn more about the target system and its services, you can also try using additional network reconnaissance tools.

2 Likes

Ok, thank you so much! I try with other filters.

I have the same issue, the vpn is correctly setted i can ping the machines but when I try to nmap the ports are in ignored state, I tried to change the network interface of the vm and I tried to disable my gateway firewall but nmap still doesn’t work. Did you manage to solve it?