Hi, new to the labs. Am trying to use unicornscan but getting ‘send exiting main didn’t connect, exiting: system error Interrupted system call’. Not having any issues with any other tools up til now. VPN is connected. I have connectivity. Any ideas?

It appears to be an issue with OneTwoPunch and Unicorn scan in general having fussy compatibility when operating over a VPN connection.

See this thread for details - Scanning HACKTHEBOX one2punch seems to hang · Issue #5 · superkojiman/onetwopunch · GitHub

Additionally, when attempting to use these tools on my own examination, similar results were experienced. Not sure of a direct fix, but it appears the VPN could be the underlying issue.

Ok, worked in OSCP labs for me. But will have to scratch it from the list here then. Thanks for the feedback.

Just FYI, I think unicornscan worked with the OSCP labs because the VPN connection used a Tap adapter. HTB uses Tun. I believe when i wrote the OSCP exam it used Tun as well so unicornscan may not work during the exam.
Tap uses switching (layer 2) whereas Tun uses layer 3. It seems unicornscan has trouble scanning devices not on the same local network.