Starting Point - Unable to connect with SMB1

Note: I’m brand new to this…

On the Enumeration step of Starting Point I am running into an issue with the smbclient.

Running smbclient -N -L \\\\10.10.10.27\\ does list out the file shares, but directly following it emits an error.

SMB1 disabled -- no workgroup available

This terminates and pops me back to the shell. After some googling, I ran across suggestions to lower the client min protocol to NT1 within /etc/samba/smb.conf. That yields another, different, error.

Reconnecting with SMB1 for workgroup listing.                                                                                                
do_connect: Connection to 10.10.10.27 failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)                                                            
Unable to connect with SMB1 -- no workgroup available

I think I’ve reached the point at which my googling will not progress me any further. Any help would be greatly appreciated.

Thanks in advance.

I was able to get things working, I can only imagine that I had made a mistake in the process early on that I did not catch.

Please disregard.

Hi,

I am getting same error. what was the mistake that you corrected?

thanks!

Type your comment> @ponaba said:

Hi,

I am getting same error. what was the mistake that you corrected?

thanks!

You need to omit the -L from smbclient -N -L \\10.10.10.27\ command.

so you’d do:

smbclient -N -L \\\\10.10.10.27\\

then

smbclient -N \\\\10.10.10.27\\backups

should work then. get the file, then exit.

2 Likes

I tr> @zombiebruh said:

Type your comment> @ponaba said:

Hi,

I am getting same error. what was the mistake that you corrected?

thanks!

You need to omit the -L from smbclient -N -L \\10.10.10.27\ command.

so you’d do:

smbclient -N -L \\\\10.10.10.27\\

then

smbclient -N \\\\10.10.10.27\\backups

should work then. get the file, then exit.

I tried to follow that suggestion and this is what I get:
It asked me for what i assumed was my root pw but when i tried that it didn’t do anything.

root@kali:/home/kali# smbclient -L \\10.10.10.27\
Enter WORKGROUP\root’s password:

    Sharename       Type      Comment
    ---------       ----      -------
    ADMIN$          Disk      Remote Admin
    backups         Disk      
    C$              Disk      Default share
    IPC$            IPC       Remote IPC

SMB1 disabled – no workgroup available
root@kali:/home/kali#

Try running just:

smbclient -N \\\\10.10.10.27/backups

@preemchoomba said:
Try running just:

smbclient -N \\\\10.10.10.27/backups

I tried this command and this is what it shows to me.

Try “help” to get a list of possible commands
smb: >

Try this smbclient //ip_address/share/ -m SMB3 -U or you can simply mount after check creds with crackmapexec

I think I changed the min protocol by editing the /etc/samba/smb.conf file to a still supported SMB1 protocol. Under the WORKGROUP client min protocol = CORE

Type your comment

Try smbclient ///backups

This worked after trying for like an hour. Thanks so much

Hello am new here , i was having same issue as you so i tried this “smbclient //10.129.78.24/workshares -U” and it worked for me eliminate the quotes when you are typing in the commad