Starting point SMB error

Having trouble with Samba on starting point
Followed steps and entered
smbclient - N - L \\10.10.10.27\
I get an error returned
NT_STATUS_TIMEOUT_IO

looks like your connection timed out.Can you check if your connection to the vpn is still open?
Also the correct command is
smbclient -N -L \\10.10.10.27\
Hope this helps!

Will try now and let you know, thanks

Shows I am connected to vpn, tried with the command you provided and I still get the same error

do_connect: Connection to 10.10.10.27 failed (Error NT_STATUS_IO_TIMEOUT)

I’m using parrot OS, I tried it on kali too and same issue, tried switching from bridged adapter to NAT, same issue
I’ve never used samba before but apparently you have to do something to the conf file - not sure if that is actually the case, I did try on kali however still no luck

Nevermind I sorted it, the command I had to use was smbclient - N - L \10.10.10.27\

Thank you for your help as I wouldn’t haven’t managed it without you

I now have a new issue
SMB1 disabled - - no workgroup available

I have tried changing client min and max protocols but not resolved the issue

Type your comment> @razevero said:

I now have a new issue
SMB1 disabled - - no workgroup available

I have tried changing client min and max protocols but not resolved the issue

I’m having the same issue, were you able to solve it?

I just solved it in another way, if you have another machine that is not kali (debian, ubuntu, whatever you like) for example i used my windows wsl subsystem (since i though that it would not enforce rules as strictly as a real linux) and then try to connect, it should work.

I reached this conclussion since i searched the NT_STATUS_IO_TIMEOUT error on google and it showed a stackoverflock thread where someone mentioned that it can happens when you try to connect to a machine with an outdated and insecure SMB version, they proposed adding this settings to the smb.conf file:

client min protocol = CORE
client max protocol = SMB3

But that didn’t work, so that’s how i came to the posibility of ussing wsl… and well it worked. So let’s try another distro, maybe that works for you, happy hacking people!!!