Dancing Starting Point Machine won't let me SMB correctly

Won’t let me SMB off with linux machine. Anyone knows how to fix this problem?
I did a fresh install of kali linux.

└─# smbclient --list (IP)
Enter WORKGROUP\root’s password:

    Sharename       Type      Comment
    ---------       ----      -------
    ADMIN$          Disk      Remote Admin
    C$              Disk      Default share
    IPC$            IPC       Remote IPC
    WorkShares      Disk      

Reconnecting with SMB1 for workgroup listing.
do_connect: Connection to (IP) failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
Unable to connect with SMB1 – no workgroup available

on the PWNbox with Parrot OS it worked fine though.
I tried editing the SMB configuration file in etc/samba/

on Global :

Kali configuration (use kali-tweaks to change it)

By default a Kali system should be configured for wide compatibility,

to easily interact with servers using old vulnerable protocols.

client min protocol = LANMAN1


Change this to the workgroup/NT-domain name your Samba server will part of

workgroup = WORKGROUP
client max protocol = SMB3

I had added client Max protocol and I tried changing min protocol to CORE but CORE made it worse.