Starting Box - NT_STATUS_RESOURCE_NAME_NOT_FOUND

During starting box I can run

smbclient -N -L \\\\10.10.10.27\\backups

I get this response:

┌─[✗]─[user@parrot]─[//]
└──╼ $smbclient -N -L \\\\10.10.10.27\\backups

	Sharename       Type      Comment
	---------       ----      -------
	ADMIN$          Disk      Remote Admin
	backups         Disk      
	C$              Disk      Default share
	IPC$            IPC       Remote IPC
Reconnecting with SMB1 for workgroup listing.
do_connect: Connection to 10.10.10.27 failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
Unable to connect with SMB1 -- no workgroup available

I’ve googled NT_STATUS_RESOURCE_NAME_NOT_FOUND and I’ve added
client min protocol = NT1 and client max protocol = SMB3 to smb.conf but I still get the same issue, anyone able to help?

Enter ping 10.10.10.27 in the terminal if the server is not available, then check your connection to the VPN, and note that the VPN of the starting point and the VPN of access to other machines are different. Good luck to you)

did you restart the samba server after updating the config file?

systemctl restart smbd.service

i think that might’ve been what finally got this to work for me but i’m not sure, i was stuck for quite a while.

You can connect to it by simply issuing smbclient -N \\10.10.10.27\backups. The -L flag makes it lists the share.

Im having the same issue, is there anyway to fix this yet?

Can confirm. Resetting smb service is unnecessary, omit the -L option to connect.

nothing has changed hahahahaha

why omit the -L option to connect is successfully?that’s awsome,could you tell me the reason?

Use smbclient -N //10.10.10.27/backups

(’\’ doesn’t work )

Omitting -L because smbclient outputs list of available services on the terminal. And (I think) this interrupts the it from starting an SMB session

For reference : Linux smbclient Command Tutorial – LinuxTect

Using Command Prompt instead of powershell fixed it for me EVERYTIME!!