Starting Point: Three (Proxy Error, seems like a server issue?)

Hey there, I am having an issue with the Tier 1 starting point box called “Three”, but I think it may be the box and not me.

When trying to view the S3 service in my browser after adding http://s3.thetoppers.htb/ to my hosts file, I am getting the following error when navigating to the URL in my browser:

“Proxy Error
The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request”

I followed the walkthrough, but I think this is actually an issue with the box?

I also noticed that when I use gobuster as the writeup suggests, I am getting “s3.thetoppers.htb (Status: 502)”, where the write-up indicates that I should get “Status: 404”.

Any help would be appreciated. Thanks in advance!

Hi,

Hope you are fine today.

Try to add the subdomain to the etc hosts manually.

Go to home in your Linux environment, and type: sudo nano /etc/hosts

You will see the hosts list and after the last line, in a new line, type

10.129.50.83 thetoppers.htb s3.thetoppers.htb

Save it, and refresh the browser, it will be there now.

Regards.

Howdy! Not sure if you already figured it out, but I had the same issue and it turns out it’s due to the way hosts file entries are processed. Any hosts using the same IP address must be on the same line or only the first entry will be processed, so eg:

10.129.50.83 thetoppers.htb
10.129.50.83 s3.thetoppers.htb

should be:

10.129.50.83 thetoppers.htb s3.thetoppers.htb

Hope this helps!

1 Like

Thanks for the suggestion, I just tried that and I am still not having any success

Here is my hosts file (I have tried a few variations):
hosts

Unfortunately I am still having the same issue. This is my hosts file:

Host addresses

127.0.0.1 localhost
127.0.1.1 vmwarevirtualplatform
::1 localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
10.129.21.128 thetoppers.htb s3.thetoppers.htb

And here is the error I am getting in the browser:
browser

You’re definitely not alone. I’m in the same boat with the exact same proxy error.

This s3 bucket sucks. Increase the memory or it won’t work at all. Getting stupid errors all the time.

I just took a look at the starting point discord channel, it seems like there are a few people having this issue.

Do I need to put a request to HTB to increase the memory assigned to this S3 service?

so frustrating, have you managed to get past this?

I contacted the support team. They said they are aware of the issue and fixing it.

2 Likes

Looks like it’s fixed now. Getting the expected {"status": "running"} instead of the proxy error.

I am getting the 502 Proxy Error :frowning: I’ve tried switching vpn’s but still no luck.

I am having the same Proxy Error

Yup, still having the same issue

I was getting the same error too no matter if I followed everything in the walkthrough. I ended up just doing it through pwnbox and was able to get the flag that way.

Same issue here.

even if the lab gives you error 502, you can still finish it.

Good afternoon from Spain! What does “through pwnbox” means?! I can`t get it done :frowning:

@cmarrod pwnbox is an alternative to using openvpn to interact with the target. you’ll basically interact with the target using a virtual desktop hosted by HtB.

So two ways of interacting with your target (1) with openvpn - VM is from the user’s computer and pwnbox- vm hosted by HtB.

Hope that helps.

Thanks!! And how do I open the virtual desktop? Sorry for my stupid doubts… I`m taking baby steps!