Official Quantum-Safe Discussion

Official discussion thread for Quantum-Safe. Please do not post any spoilers or big hints.

Nice custom made challenge. You need to know some basic maths to solve this one… I don’t know if i did it the smartest way but it was fun

Thx to Ir0nstone for creating this one

Nice challenge ! Thanks Ir0nStone.

However, something seems weird … When I run my script, I find the correct flag, but with a character missing !
Am I the only one ? I think the (5694, -8016, 6237) (9th one) is the problem

You can PM me if needed :smiley:

1 Like

At first I had the same problem: One character of the flag was missing. In my case it was the 36th character, and not no. 9

I figured it out after a while. Without that character the flag didn’t make sense grammatically…

Really nice challenge, my solution was not probably the intended one, but I got there in the end. Mine flag was not missing any characters so probably it was fixed already.

If anyone need a help feel free to PM me.

Nice challenge! solved it after a week without doing the intended method. Did anyone solve it using the intended method? Please DM me!

Well I finally maneged to get it (after a lot of waiting…) probably not using the intended way like everyone…
So a tip: be patient

I solved the challenge but I had to bruteforce r. Is there a clean way to calculate r, maybe someone can write me a PM about this:+1:

Would also be interested in learning a more mathematical solution… messaged a math phd friend of mine after getting the flag… so maybe they’ll be able to tell me. Feel like I did a “smart brute force” of r … took only about 30 seconds to run and gave me actually 324 different r vectors that all work…

Guys I’ve got this error while running source.sage, why:

$ sage source.sage
Traceback (most recent call last):
  File "/home/bambam/crypto/quantumsafe/crypto_quantum_safe/", line 16, in <module>
    for c in flag:
NameError: name 'flag' is not defined. Did you mean: 'float'?

Nice challenge
If you have found the flag but are missing some letters, what is missing is the use of Rond
If you are stuck or need help, do not hesitate to DM