Official Simple Encryptor Discussion

Official discussion thread for Simple Encryptor. Please do not post any spoilers or big hints.

1 Like


Any tip on where to look at?

I think I figure out the encryption mechanism but I feel I’m missing a piece of the puzzle.

have you tried checking how things are beeing written in the file?

Got it! thanks!!

Interesting challenge i debugged until the srand function but still not yet clear for me :stuck_out_tongue:

same, I understand that you need to use the seed, but i am still unable to “decode” or undo the flag

Any hints on what im doing wrong if i’m only getting some of the correct flag chars? Like first, 3rd, 4th are right, and the last 8 look right. Some inbetween aswell. But others are just missing or wrong.

Can anyone help with this challenge? I have tried many things and I feel like i’m missing something simple.

same for me, I feel like is something about variables types and conversions but I couldn’t figure out yet

Have the same problem. I can read the exact same parts as you described, but the rest is still “encrypted”. Have you or anyone else been able to fix this problem? If so, could someone give me a little nudge to solve this problem :slight_smile:
Edit: Solved it…6hours just because I missed one letter in my code.

Hint from agusanchez86 is more then enough

For everyone struggling with incorrect decoding of some symbols - make sure that you’re bit shifting a suitable data type

Hi, I don’t understand why my original solution didn’t work so I’ve solved it in another way.
can someone who solved it in the intended way explain to me what did I do wrong?

Sure, DM me.

1 Like

Anyone willing to help out? I’ve disassembled, decompiled, and reproduced line for line the reverse of the encryption process, but I’m getting nonsense when I decrypt it (e.g. rarely any printable characters) - which clearly means, I’ve missed something (or done something wrong).

I’ve gone bit-by-bit in my conversions, by hand even… so I must be missing something. :open_mouth:

EDIT: I figured out why by comparing the assembly of the encrypt and decrypt and doing a little bit of research around the opcodes - but now I’m fighting my compiler to generate an opcode the language doesn’t support by default… still open to any help anyone is willing to offer!


I tried to figure out the seed which decodes to the first four flag characters but I could at most get 3.

Could I PM someone for code checking?

I can help you with that part at least; feel free to pm me!

Can I PM someone with my current findings, and who could give me a nudge? I’m kind of stuck figuring out the right algorithm.

I’m at a loss here, can’t open the related zip files as it asks for a password.
Tried cracking it with John The Ripper, without luck.

Is this part of the challenge, or am I just missing a password?

the password for the zip is right there when you click to download. Its “hackthebox”.

Hello, i’m having a segmentation fault when running it (i haven’t modified the binary for now)