No connection to pwnbox from a VM


I had an issue these days with the SSH connection for Linux Fundamentals course. I realised since something is blocking the ports of the pwnbox (?).

That’s probably why for example metasploit can’t find the modules… Is there something to set to avoid this problem ?

At first I tried to launch attacks from my Kali Linux VM terminal with metasploit but attacks are stopped by antivirus in my host machine. That’s why I launched pwnbox from my VM, but there seems not to be any connection.

So I disabled temporarily the antivirus but to no avail…

Any clue? Thanx :3

I hope that this does not sound foolish, but did you download the VPN file and use openvpn with sudo to run the connection?

The vpn is to be used both for the pwnbox and for my vm ? I never did for the pwnbox and well I wasn’t using it yesterday with my kali vm while launching metasploit at first; I added it later, I probably should have close the terminals I was using and starting again

I did not think that we needed to have it for the Pwnbox, but it is worth a try. I also had issues where my personal security items were blocking everything. Bitdenfender made it so difficult. I also tried using different locations as well. I had to try multiple times to run the exploits, but it did eventually run.

Thanx a lot! The issue was simply that I typed @academy instead of @cademy

Anyway thanx to you I understood what’s a VPN for. I did not grasp the concept entirely and these days I had to look it through.
At least I won’t try to attack my antivirus anymore…
Thanx a lot!