impacket issues

hey htb community :: long shot BUT is anyone else having issues with impacket? no matter what I do I don’t get stable version. I’m sure I haven’t been able to complete active for that reason.
And I keep getting weird errors when I run latest gits: One of them is:
SMBTransport instance has no attribute ‘setRemoteHost’

Yes, of course I’ve googled it, but I didn’t find any glaringly obvious fix. ASolino, its author suggests a pull on a dev branch…have tried that and made my configs even messier, or at the very least nonfunctional
I found nothing else.

Anyone any ideas?

I solved the ACTIVE using the same impacket script. It works completely fine , I still use it. Would you mind having a fresh installation. If the issues do not get solved let me know I will share the impacket version I am using.

hey mate…thanks for your reply! Can you expand on fresh installation? Remove impacket all together? The native one in Kali or separate ones people (including me :wink: - may add from github? Full Kali reinstall and start from the beginning? At the moment I’m quite busy, so anything too disruptive will have to wait…mind sharing impacket version anyway? And how you installed/configured it? if at all…?
Thanks in advance !!