Can't bypass sudo password on ParrotSec

I went to remove the sudo password for myself:

sudo visudo
user        ALL=(ALL:ALL) NOPASSWD: ALL

But it didn’t take, and parrot still asks for my password when invoking sudo permissions. So I tried:

sudo visudo
user      ALL=(ALL) NOPASSWD: ALL

And got the same issue. Invoking sudo still requires my password.

Before anyone asks, yes, my username is ‘user’ and yes I am aware this is a sEcUrItY rIsK deep breath this is a penetration testing distro. Everything I run is run as root.

Looks like it does the same with kali, very odd. But anyways; I’m not one to respond without providing an solution (somewhat, lol).

since security is not our priority here, instead of assigning those permissions to a certain user you can (albeit even more dangerously i guess) add %sudo ALL=(ALL) NOPASSWD: ALL to /etc/sudoers (or via visudo)

What %sudo ALL=(ALL) NOPASSWD: ALL is that anybody who is part of the “sudo” group to execute anything, and I mean ANYTHING with sudo permissions.

Here are the contents of my /etc/sudoers file: https://pastebin.com/z790RRbX
Also PS: please backup your original sudoers before doing this haha, or take a snapshot!

Type your comment> @PapyrusTheGuru said:

Looks like it does the same with kali, very odd. But anyways; I’m not one to respond without providing an solution (somewhat, lol).

since security is not our priority here, instead of assigning those permissions to a certain user you can (albeit even more dangerously i guess) add %sudo ALL=(ALL) NOPASSWD: ALL to /etc/sudoers (or via visudo)

What %sudo ALL=(ALL) NOPASSWD: ALL is that anybody who is part of the “sudo” group to execute anything, and I mean ANYTHING with sudo permissions.

Here are the contents of my /etc/sudoers file: https://pastebin.com/z790RRbX
Also PS: please backup your original sudoers before doing this haha, or take a snapshot!

Unfortunately I have already tried this as well with no success. Its very odd but at least I’m not the only one getting this issue. Hopefully its just a bug that will get fixed in the next sudo update.

Edit: did changing group permissions work for you?

Type your comment> @LMAY75 said:

Type your comment> @PapyrusTheGuru said:

Looks like it does the same with kali, very odd. But anyways; I’m not one to respond without providing an solution (somewhat, lol).

since security is not our priority here, instead of assigning those permissions to a certain user you can (albeit even more dangerously i guess) add %sudo ALL=(ALL) NOPASSWD: ALL to /etc/sudoers (or via visudo)

What %sudo ALL=(ALL) NOPASSWD: ALL is that anybody who is part of the “sudo” group to execute anything, and I mean ANYTHING with sudo permissions.

Here are the contents of my /etc/sudoers file: https://pastebin.com/z790RRbX
Also PS: please backup your original sudoers before doing this haha, or take a snapshot!

Unfortunately I have already tried this as well with no success. Its very odd but at least I’m not the only one getting this issue. Hopefully its just a bug that will get fixed in the next sudo update.

Edit: did changing group permissions work for you?

Yep, changing the sudo group permissions worked for me. IF you look in the pastebin I specified where and what to copy, that seemed to work perfectly fine with me, although I don’t use parrot, I use kali. But, I still experienced the same issue as you.

Type your comment> @PapyrusTheGuru said:

Type your comment> @LMAY75 said:

Type your comment> @PapyrusTheGuru said:

Looks like it does the same with kali, very odd. But anyways; I’m not one to respond without providing an solution (somewhat, lol).

since security is not our priority here, instead of assigning those permissions to a certain user you can (albeit even more dangerously i guess) add %sudo ALL=(ALL) NOPASSWD: ALL to /etc/sudoers (or via visudo)

What %sudo ALL=(ALL) NOPASSWD: ALL is that anybody who is part of the “sudo” group to execute anything, and I mean ANYTHING with sudo permissions.

Here are the contents of my /etc/sudoers file: https://pastebin.com/z790RRbX
Also PS: please backup your original sudoers before doing this haha, or take a snapshot!

Unfortunately I have already tried this as well with no success. Its very odd but at least I’m not the only one getting this issue. Hopefully its just a bug that will get fixed in the next sudo update.

Edit: did changing group permissions work for you?

Yep, changing the sudo group permissions worked for me. IF you look in the pastebin I specified where and what to copy, that seemed to work perfectly fine with me, although I don’t use parrot, I use kali. But, I still experienced the same issue as you.

Looking at your pastebin I realized I forgot to comment out the old group sudo permissions when I had tried that approach. Will try again and let you know how it works

Type your comment> @LMAY75 said:

Type your comment> @PapyrusTheGuru said:

Type your comment> @LMAY75 said:

Type your comment> @PapyrusTheGuru said:

Looks like it does the same with kali, very odd. But anyways; I’m not one to respond without providing an solution (somewhat, lol).

since security is not our priority here, instead of assigning those permissions to a certain user you can (albeit even more dangerously i guess) add %sudo ALL=(ALL) NOPASSWD: ALL to /etc/sudoers (or via visudo)

What %sudo ALL=(ALL) NOPASSWD: ALL is that anybody who is part of the “sudo” group to execute anything, and I mean ANYTHING with sudo permissions.

Here are the contents of my /etc/sudoers file: https://pastebin.com/z790RRbX
Also PS: please backup your original sudoers before doing this haha, or take a snapshot!

Unfortunately I have already tried this as well with no success. Its very odd but at least I’m not the only one getting this issue. Hopefully its just a bug that will get fixed in the next sudo update.

Edit: did changing group permissions work for you?

Yep, changing the sudo group permissions worked for me. IF you look in the pastebin I specified where and what to copy, that seemed to work perfectly fine with me, although I don’t use parrot, I use kali. But, I still experienced the same issue as you.

Looking at your pastebin I realized I forgot to comment out the old group sudo permissions when I had tried that approach. Will try again and let you know how it works

Sure! hope it works.

Type your comment> @PapyrusTheGuru said:

Type your comment> @LMAY75 said:

Type your comment> @PapyrusTheGuru said:

Type your comment> @LMAY75 said:

Type your comment> @PapyrusTheGuru said:

Looks like it does the same with kali, very odd. But anyways; I’m not one to respond without providing an solution (somewhat, lol).

since security is not our priority here, instead of assigning those permissions to a certain user you can (albeit even more dangerously i guess) add %sudo ALL=(ALL) NOPASSWD: ALL to /etc/sudoers (or via visudo)

What %sudo ALL=(ALL) NOPASSWD: ALL is that anybody who is part of the “sudo” group to execute anything, and I mean ANYTHING with sudo permissions.

Here are the contents of my /etc/sudoers file: https://pastebin.com/z790RRbX
Also PS: please backup your original sudoers before doing this haha, or take a snapshot!

Unfortunately I have already tried this as well with no success. Its very odd but at least I’m not the only one getting this issue. Hopefully its just a bug that will get fixed in the next sudo update.

Edit: did changing group permissions work for you?

Yep, changing the sudo group permissions worked for me. IF you look in the pastebin I specified where and what to copy, that seemed to work perfectly fine with me, although I don’t use parrot, I use kali. But, I still experienced the same issue as you.

Looking at your pastebin I realized I forgot to comment out the old group sudo permissions when I had tried that approach. Will try again and let you know how it works

Sure! hope it works.

Nope… yea this is really strange. Will raise the issue with parrot support

Type your comment> @LMAY75 said:

Type your comment> @PapyrusTheGuru said:

Type your comment> @LMAY75 said:

Type your comment> @PapyrusTheGuru said:

Type your comment> @LMAY75 said:

Type your comment> @PapyrusTheGuru said:

Looks like it does the same with kali, very odd. But anyways; I’m not one to respond without providing an solution (somewhat, lol).

since security is not our priority here, instead of assigning those permissions to a certain user you can (albeit even more dangerously i guess) add %sudo ALL=(ALL) NOPASSWD: ALL to /etc/sudoers (or via visudo)

What %sudo ALL=(ALL) NOPASSWD: ALL is that anybody who is part of the “sudo” group to execute anything, and I mean ANYTHING with sudo permissions.

Here are the contents of my /etc/sudoers file: https://pastebin.com/z790RRbX
Also PS: please backup your original sudoers before doing this haha, or take a snapshot!

Unfortunately I have already tried this as well with no success. Its very odd but at least I’m not the only one getting this issue. Hopefully its just a bug that will get fixed in the next sudo update.

Edit: did changing group permissions work for you?

Yep, changing the sudo group permissions worked for me. IF you look in the pastebin I specified where and what to copy, that seemed to work perfectly fine with me, although I don’t use parrot, I use kali. But, I still experienced the same issue as you.

Looking at your pastebin I realized I forgot to comment out the old group sudo permissions when I had tried that approach. Will try again and let you know how it works

Sure! hope it works.

Nope… yea this is really strange. Will raise the issue with parrot support

Wow, you’re totally right. It’s definitely an issue with parrot then.

You can do a work around for this btw…

Just a one time password for however long you want. It’s per minute.

Details

TLDR

Defaults        env_reset, timestamp_timeout=XX

change xx to time you want. Again 1 is 1 minute 60 = 1 hour ect ect.

Type your comment> @PrivacyMonk3y said:

You can do a work around for this btw…

Just a one time password for however long you want. It’s per minute.

Details

TLDR

Defaults        env_reset, timestamp_timeout=XX

change xx to time you want. Again 1 is 1 minute 60 = 1 hour ect ect.

When I rebuilt my OS (for the 3rd time this month) I just forced Parrot to accept a default root user.

That is an interesting idea tho, good to know for the future

I know this is a super old thread, but I had a hard time finding an answer (First time using Parrot) Haven’t seen this issue with Kali before. In the sudoers file there’s a line at the bottom

@includedir /etc/sudoers.d

It points to the /etc/sudoers.d directory which has a file 10-installer that also holds sudo permissions. It looks as though the sudo command will follow the least privileged setting so changing the sudoers setting isn’t enough. You can either comment out the includedir setting, or you can change the sudo permissions in the 10-installer file. Up to you, but either way will let you do passwordless sudo.