Why Can't I use the Sudo command on the HTB Linux Fundamentals?

Hey, I am a noobie here and I was following a youtube tutorial that goes through the linux file system… Anyway, it requires you to use the sudo command for some things and I followed the tutorial exactly but whenever I use the sudo command in the Parrot OS terminal on HTB’s Linux fundamentals course it spits back this error message:
"We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.
#3) With great power comes great responsibility."

Then it asks for a password… I have tried the default passwords like user and toor, but it absolutely will not let me move past this message. I have tried using my HTB password too, I have no idea what the heck I’m missing and I can’t find anything helpful online. What the heck did I miss?

P.S. This is the youtube tutorial: the Linux File System explained in 1,233 seconds // Linux for Hackers // EP 2 - YouTube

If you are on the pwnbox, then look at the desktop. The password should be in cat ~/Desktop/my_credentials.txt
-onthesauce