Stuck in Introduction to Windows Command Line - User and Group Management

So the question im stuck for is “Connect to the target host and search for a domain user with the given name of Robert. What is this users Surname?”

with tags as shown "SSH to with user “mtanaka” and password “HTB_@cademy_stdnt!” "

but the problem is, user mtanaka doesn’t exist & i can ssh with user htb-academy, but i cant find this Robert no matter what i try

i know the answer is something like this “Get-ADUser -Filter *” or “Get-ADUser -Identity Robert”

any help :frowning: ?

Hey! It looks like you have the answer in your post. I just booted this up and it works with the solution you have. Also don’t forget about some of Microsoft’s help pages: Get-ADUser (ActiveDirectory) | Microsoft Learn



im confused how you can get it working, are you ssh as mtanaka? or htb-student, im completely lost on this, or can u just spoil me the surname of this robert XD

here is my result

PS C:\Users\htb-student> Get-ADUser -Filter *
Get-ADUser : The server has rejected the client credentials.
At line:1 char:1
 Get-ADUser -Filter *
     CategoryInfo          : SecurityError: (:) [Get-ADUser], AuthenticationException
     FullyQualifiedErrorId : ActiveDirectoryCmdlet:System.Security.Authentication.AuthenticationException,Microsoft.ActiveDirectory.Management.Commands.GetADUser

Solved it, apparently you cant ssh as mtanaka

the solution is use xfreerdp to log in as mtanaka

finally i can sleep peacefully XD


Hey sorry for the late response! I logged in just fine from the pwnbox cli with ssh mtanaka@TARGETIP.

But regardless, glad you solved it.


Sorry I have resolved!