Starting Point - Tier 2 - Archetype Error

So I am kind of lost at this point. I am running into this output:

ERROR: pip’s dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
crackmapexec 5.2.2 requires bs4<0.0.2,>=0.0.1, which is not installed.
crackmapexec 5.2.2 requires impacket<0.10.0,>=0.9.23, but you have impacket 0.10.1.dev1+20220720.103933.3c6713e3 which is incompatible.
crackmapexec 5.2.2 requires neo4j<5.0.0,>=4.1.1, but you have neo4j 1.7.0.dev0 which is incompatible.
crackmapexec 5.2.2 requires pylnk3<0.4.0,>=0.3.0, but you have pylnk3 0.4.2 which is incompatible.
Successfully installed impacket-0.10.1.dev1+20220720.103933.3c6713e3

└─$ ls
build examples LICENSE requirements-test.txt tox.ini impacket requirements.txt
Dockerfile impacket.egg-info tests

└─$ examples

└─$ python3 ARCHETYPE/sql_svc@{} -windows-auth
Impacket v0.10.1.dev1+20220720.103933.3c6713e3 - Copyright 2022 SecureAuth Corporation

Traceback (most recent call last):
File “/home/kali/impacket/examples/”, line 169, in
File “/home/kali/.local/lib/python3.10/site-packages/impacket/”, line 531, in connect
af, socktype, proto, canonname, sa = socket.getaddrinfo(self.server, self.port, 0, socket.SOCK_STREAM)[0]
File “/usr/lib/python3.10/”, line 955, in getaddrinfo
for res in _socket.getaddrinfo(host, port, family, type, proto, flags):
socket.gaierror: [Errno -2] Name or service not known


I have tried deleting the install folder and tried following the instructions outlined in the walk through multiple times.

Any advice?