Starting point; can't parse ufw as IP address

I might have a bit of a facepalm when I get the answer, I’m working through the starting point and it’s going well so far. Unfortunately I’m stuck at the point where I enter
nc -lvnp 443 ufw allow from proto tcp to any port 80,443

I get the response “Can’t parse ufw as IP address”. The rest of the challenge worked as it should (and if it didn’t I found out eventually) but I don’t understand what’s happening here. I tried Googling but no answers were found. I even copied and pasted the line just to make sure I didn’t make any errors in typing it out but this didn’t help either. What’s happening and what do I do to fix it? Is it maybe something in my own settings (VM)?


Just to check, you are typing this as different commands arent you?

For example:

ufw allow from proto tcp to any port 80,443 is a command.
nc -lvnp 443 is a command.

The first one looks to modify the firewall to allow traffic to ports 80 and 443 on your machine. It goes against the grain but I’d suggest that you dont use your “Hacking” machine as a day-to-day machine and just disable the firewall. It will annoy you trying to turn it on and off for various boxes.

The second command sets up netat to listen on port 443 and be verbose with its output.