RastaLab Discussion

Since there is no discussion on Rasta Lab, I decided to open this. Feel free to ask/answer related to hints on Rasta.

I have a shell, but I want to go to meterpreter. Can anyone help me? Used some tools, but I’m having some troubles again. Can sb PM me?

hey, I am stuck at getting the shell. I know how to do it, i think, but my payload is not giving me a shell

Type your comment> @aitipiaty said:

Since there is no discussion on Rasta Lab, I decided to open this. Feel free to ask/answer related to hints on Rasta.

Can you give me a hint about initial foothoold ? I’m try in higher port but no luck with bf.


Can someone DM me for rastalabs help ?

Getting difficulties on the OSINT part, not finding the information I should find, I just need a direction.

Hi all,

I found epugh_adm’s creds but i am currently stuck in order to access SQ01.

Can someone DM me for some help please?

Thank you :wink:

Hi all, I’m on the initial foothold machine and found a hash by domain attack. I tried cracking that hash but been unable to. Anyone that could give me a DM for general direction to move from that machine?


Is anyone available to point me in the right direction with the initial foothold. I have a set of credentials and access to a service that can target other users… I’ve been able to coerce file downloads (HTAs, Maldocs, exes, etc.) but haven’t been able to get callbacks. Any help would be appreciated as I’m stuck and it seems like there is no way to progress without going through this step.

Set up a Windows 10 VM with a current defender and check if your payload gets blocked. Ultimately, a lab setup with Visual Studio to compile various C# projects is required. Maybe build a really simple TCP reverse shell from source for the beginning, just to get some kind of access and be able to look around.

Is everything required for the initial OSINT tasks still available online?
I can see some social media profiles on one platform but no others.

For the life of me I cannot get a reverse shell on WS06 to work properly.

I’ve tried different payloads, different file formats, different handlers, different ports and nothing will allow me to stay connected for more than 10 seconds. I’ll be lucky if I can type in a single command before getting kicked off.

I’ve been able to find the flag and I’ve found the folders I need to search through, but it’s taken me hours to do something that should have been literally 5 minutes so I’ve given up moving forward until I can find a way to get a stable shell.

Can someone please let me know what I’m doing wrong because the box has been reset several times and even just after a reset I can’t get a stable shell.

I’ve even tried connecting to a reverse shell from within the internal network but that didn’t work either, I get a connection and then 10 seconds later it’s disconnected again.

WS04 I managed to get a shell without an issue and I’ve been able to keep it connected for the entire day.