Pwnbox does not let me write a password in Linux fundamentals

Hey guys! I’m a total beginner on Hack The Box and I started studying the Linux fundamentals course. In the section “System information” I started the pwnbox app and in powershell I wrote the command “systemctl start ssh”. This lets me to select user and I chose numer 2 (htb-ac-775873). After this pwnbox asks me to write the password, but for some reason I cannot type anything. Therefore I am not able to proceed with the exercize. I have been trying to find the answer to why pwnbox does not let me type password but I’m stumped! Is there any solution to this where I could continue the exercize using pwnbox? I currently have a free account on HTB and I use Macbook Pro 2020 with M1 chip with macOS Big Sur. Would love it if there’s a solution where I don’t have to update the OS because updating the OS would mess up my other software that I am using.

Hello, there. This is normal, just continue typing your password and hit enter after finish it. Almost every password you will be asked is going to be like this. Just because you are not seeing it doesn’t mean that it isn’t being sent to terminal.

1 Like

Thanks a lot, that worked! However I have another problem, I don’t know if you can help me with this one. I tried anwering the questions in Linux fundamentals with account “htb-ac-775873” but it gives me the wrong answers even though the prompts are correct. I suspect the problem being that I should ssh with htb-student, but I am not able to since I don’t have an IP address. The ones that I found on different forums don’t work.

Under pwnbox only reads " SSH to with user “htb-student” and password “HTB_@cademy_stdnt!” Is there something I don’t understand or should I be able to get the IP address from somewhere else? Pwnbox location is in UK, but I reside in Finland so I am wondering whether this is a location issue or something like that. Any ideas how I could fix this?

Are you trying to answer the question connecting via ssh to pwnbox? If yes you are misunderstanding the objective.

Right above questions there are a button called “Target: Click here to spawn the target system!”. Once you click on it, it will spawn a machine for you to do all these things you learned in the section. Try to find it and tell me if it was your problem.

Also remember to connect to the vpn using “sudo openvpn vpn_file”

That worked, thanks a lot again! For some reason it did not let me open the vpn-file with sudo command but I was able to answer to the questions, so that’s the most important thing.

1 Like

Try using the Enter or Return key after entering your password. Sometimes applications may not show password characters as you type for security reasons, but pressing the Enter or Return key can confirm the entered password. If this doesn’t help, the problem may be with the configuration of pwnbox or the application itself.