Problem connecting to RDP in PASSWORD ATTACKS Pass the Ticket (PtT) from Windows

Hello when im trying to connect to the first exercise doesnt connect and i dont know why
xfreerdp /u:Administrator /p:AnotherC0mpl3xP4$$ /v:10.129.204.23
[18:56:50:907] [27731:27732] [INFO][com.freerdp.core] - freerdp_connect:freerdp_set_last_error_ex resetting error state
[18:56:50:907] [27731:27732] [INFO][com.freerdp.client.common.cmdline] - loading channelEx rdpdr
[18:56:50:907] [27731:27732] [INFO][com.freerdp.client.common.cmdline] - loading channelEx rdpsnd
[18:56:50:907] [27731:27732] [INFO][com.freerdp.client.common.cmdline] - loading channelEx cliprdr
[18:56:50:215] [27731:27732] [INFO][com.freerdp.primitives] - primitives autodetect, using optimized
[18:56:50:217] [27731:27732] [INFO][com.freerdp.core] - freerdp_tcp_is_hostname_resolvable:freerdp_set_last_error_ex resetting error state
[18:56:50:217] [27731:27732] [INFO][com.freerdp.core] - freerdp_tcp_connect:freerdp_set_last_error_ex resetting error state
[18:56:50:424] [27731:27732] [WARN][com.freerdp.crypto] - Certificate verification failure ‘self signed certificate (18)’ at stack position 0
[18:56:50:424] [27731:27732] [WARN][com.freerdp.crypto] - CN = MS01.inlanefreight.htb
[18:56:50:627] [27731:27732] [WARN][com.freerdp.core.nla] - SPNEGO received NTSTATUS: STATUS_LOGON_FAILURE [0xC000006D] from server
[18:56:50:628] [27731:27732] [ERROR][com.freerdp.core] - nla_recv_pdu:freerdp_set_last_error_ex ERRCONNECT_LOGON_FAILURE [0x00020014]
[18:56:50:628] [27731:27732] [ERROR][com.freerdp.core.rdp] - rdp_recv_callback: CONNECTION_STATE_NLA - nla_recv_pdu() fail
[18:56:50:628] [27731:27732] [ERROR][com.freerdp.core.transport] - transport_check_fds: transport->ReceiveCallback() - -1

If i try ping it works ping -c 2 10.129.204.23
PING 10.129.204.23 (10.129.204.23) 56(84) bytes of data.
64 bytes from 10.129.204.23: icmp_seq=1 ttl=127 time=38.9 ms
64 bytes from 10.129.204.23: icmp_seq=2 ttl=127 time=40.7 ms

— 10.129.204.23 ping statistics —
2 packets transmitted, 2 received, 0% packet loss, time 1002ms
rtt min/avg/max/mdev = 38.912/39.815/40.718/0.903 ms
Please help

  1. Validate the server’s SSL certificate: The warning message “Certificate verification failure ‘self-signed certificate (18)’” suggests that the server is using a self-signed SSL certificate. If you are connecting from the FreeRDP client, you may need to configure it to trust self-signed certificates or import the server’s certificate into the client’s trusted certificate store.
  2. Check the server’s RDP settings: Verify that the remote server is configured to allow incoming RDP connections. Ensure that the Remote Desktop service is enabled on the server, and the necessary settings are configured correctly.

the problem is the pass i have to put in single quotes

oh, did you fix it?

yess you have to put the password in single quotes

2 Likes

I’m still not able to connect. Any input?
image

try administrator instead of Administrator

2 Likes

You can also try adding /cert:ignore, which will ignore the certificate entirely.