Package Management - Can't seem to download packages? (Connection issues?)

Howdy all, I’m trying to follow along in Package Management on my Pwnbox, but I can’t seem to download packages using the commands in the lesson. It seems to be a connection issue, as far as I can tell. Below are images of what happens when I try to run the commands. (Melded together into one image because my account is too new for multiple, it seems.)

Using git to download nishang/wget to download strace

Does anyone know what I’m doing wrong/how I can fix this? I’ve already tried resetting my Pwnbox once. May be related to this topic, but I THINK this is a separate issue.

Any advice is greatly appreciated. :smiley:

I’ve just tried now from HTBs pwnbox and I had no issues. This was to the default home directory.

└──╼ [★]$ wget
--2023-07-31 17:02:09--
Resolving (,,, ...
Connecting to (||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 333388 (326K) [application/vnd.debian.binary-package]
Saving to: ‘strace_4.21-1ubuntu1_amd64.deb’

strace_4.21-1ubuntu1_amd64.deb                              100%[=========================================================================================================================================>] 325.57K   906KB/s    in 0.4s    

2023-07-31 17:02:09 (906 KB/s) - ‘strace_4.21-1ubuntu1_amd64.deb’ saved [333388/333388]

Perhaps it was just a glitch? Have you tried again since?