Official Visual Discussion

Anyone encountering this? Running a default .net 6.0 console app.

error NETSDK1004: Assets file “…/project.assets.json” not found

What do you do to stop your reverse shell being killed? Tried migrating my meterpreter, but it dies after a minute anyways.
edit: one of the local binaries works well

i used netcat for initial shell then moved from there

I got to say, getting user felt much easier than some of the ‘easy’ machines I had been working on recently. Although unexpected, it was fun learning a new programming language this weekend. :slight_smile:


is focusing on c# rev shell waste of time?


I’m pretty sure you can answer that yourself. Will it be executed, if so, why, if not, why not. :slight_smile:


Rooted. One of the boxes I enjoyed the most. Gz to the creator! :100:


I get an error:

C:\Program Files\dotnet\sdk\7.0.302\Sdks\Microsoft.NET.Sdk\targets\Microsoft.PackageDependencyResolution.targets(266,5): error NETSDK1004: Assets file 'C:\Windows\Temp\90cafe8554633817094e7423f2eacd\ReverseShell\obj\project.assets.json' not found. Run a NuGet package restore to generate this file. [C:\Windows\Temp\90cafe8554633817094e7423f2eacd\ReverseShell\ReverseShell.csproj]

    0 Warning(s)
    1 Error(s)

Does somebody have any idea? On stackoverflow people say to reconfigure visual studio, but here the app compiles everything…
I would appriciate any help :hugs:

Edit: Got it, had wrong project structure

Hi Everyone,
I’m stuck on the first step. I’ve created public GH repo with a file that website asks for. However when I pass its url, box returns the error stating that there is invalid url or there is no file. I’ve also created remote repo on my machine for that purpose but got the same effect. Should I dive deeper into configuring local git server or is there some issue with my GH repository?
So far it is one of the most frustrating CTFs I’ve participated in since I am setting up a git server instead of doing the fun stuff.


Remember that the Visual machine isn’t connected to the Internet

1 Like

I didn’t know that. Thanks!

1 Like

Ok, ok this may sound a little bit stupid, but do I need to create git repo as I’m new to git and not sure of it?

Have you worked around this? Encountered the same issue.

Been doing other machines in the meanwhile, really not interested in debugging default C# projects lol.

Me neither, bro :smiling_face_with_tear:
Working on it

Hey, Could some one give a nudge, I’ve created the git repo but I am still not getting any response by submitting my local URL to the .git, been stucked for a while there

DM me

I am not very familiar with windows boxes. Is spending time to bypass AV to run certain recon tools right way to go, for obtaining root?

Edit: Added details

i tried to upload my repository but i have an error ‘file sln not found’ :confused: can someone help me ?

Was anyone able to use VS 2019, or is 2022 needed. I see there is a workaround to get .NET6.0 on 2019, but it looks like the project needs to be compiled first. Don’t want to go down the road of installing new VS version if not needed!

Look at how .net projects can be structured, you can have a top level solution and sub-projects. Generate a valid solution and think what you can do after this.

Also, I am kinda stuck on root, can someone give me a hint please :slight_smile:

1 Like