Official Crafty Discussion

Miserable box. I got 3 chances in many many hours to get a foothold shell today, but apparently I crafted a bad payload cause I saw the grab from my webserver. Then I could just never connect again. Like what a waste of time.

need i realy My Minecraft account? (i think it is bot possible to connect with out)
Or i am to bad to find any credentials on the webside to connect to the minecraft Server

You have to pay, VIP+ got own instances

you can use pycraft

Another option than VIP+ is the release arena, which is free I think, but that’s only available when the box has just been released.

Any hints after the joining the game with TLauncher? I am new to bug bounty or CTF.

This machine is horrible. I was hoping that the machine would become stable few weeks after the release.

Unfortunately, it is not the case and with TLauncher it is not convenient. For PyCraft, samething… I am very close to give up :frowning:

I love minecraft and i can’t wait to explore new things here.

Hello everyone,

I have a issue while using the Pycraft env.

While starting the python3 start.py I always have the same issue with:
( File “/home/kali/log4J/pyCraft/minecraft/networking/connection.py”, line 596, in run
self.connection._handle_exception(e, sys.exc_info())

I also install the “requirements.txt” and the error suppose to come from here because I get this error message everytime for the requirements.txt :

But I don’t really get it and try to search about but still the same issue.

Thanks,

Usually errors of this type are provided for the python version.

I establishes a connection to the minecraft server via poc.py.
When my netcat connection establishes I get the following.

I cant type any command into the shell. What am i doing wrong?
All commands like dir help test whatever dont give me any response from the shell.
Pls Help.

Got it! Make sure to set up the poc-shell right. poc.py --userip (your IP not target IP). Didnt realize this for hours.

Hi guys!
Do I understand correctly that in order to successfully foothold, I need to deploy the MINECRAFT client and all the correct distributions, including the correct java, on your attacking machine?
How do I connect to the server after installing the launcher?

Just had to run the last command. Lost the shell, I cannot connect to the server, I cannot reset the machine. Guess I won’t Pwn it today.

Edit: Rooted. It has been frustrating. Needed to change the vpns multiple Times in order to find an accessible server

To join the server following the installation of the Launcher, make sure to sign in by the user account of your Minecraft. Then just paste the server address and port into the Multiplayer menu. For foot holding, you will most certainly need to have the Minecraft Client, and certainly, on your machine, the correct version of Java. Ensure you have the correct distributions and, of course, properly installed and configured. And, hey, you might also want to check out some of the texture packs or BSL shaders. They can really enhance your Minecraft journey and add a whole new level of immersion to the game.

Rooted. I would love to hear from some other people that rooted this box how they successfully transferred the file that ultimately got them privesc; my usual methods didn’t work and I had to resort to something a little silly (it worked, but seemed like a poor way of doing it.)

Hi everyone. I found the user flag, but is incorrect. I tried to respawn the machine but it not helped me. How to fix the issue?

Hi @Okihad! Same thing happened to me, turns out the zone you are in when you find the flag is linked to the flag submission. So to submit the flag successfully you need to also be connected to the same zone for example “US Free 3” then submit.