Machines Spawning with Wrong IP Address

I am new to HTB and when I spawn machines they come up with 10.129.X.X IP addresses instead of the 10.10.10.X address they list before I start the machine. I have tried to spawn different machines (active and retired) and still have the same issue. Appreciate any tips on the matter.

Well… that’s the il of the machine. It doesn’t necessarily have to be 10.10.x.x

*ip

@huesos35 said:

I am new to HTB and when I spawn machines they come up with 10.129.X.X IP addresses instead of the 10.10.10.X address they list before I start the machine. I have tried to spawn different machines (active and retired) and still have the same issue. Appreciate any tips on the matter.

I think it depends how you spawn it. If you are launching in the pwnbox it might be different than if you spin one up normally.

The IPs for machines come up as 10.129.X.X regardless if I use pwnbox or VM. The 10.129.X.X is out of the scope of HTB as per its rules.

@huesos35 said:

The IPs for machines come up as 10.129.X.X regardless if I use pwnbox or VM. The 10.129.X.X is out of the scope of HTB as per its rules.

What machine are you trying to spawn?

Have you tried using: https://www.hackthebox.eu/home/machines - you click on the start button and it doesn’t have a way to give you a non 10.10.x.x address.

Yes I am using that link and having this issue, I have put a support request but have not heard back. It happens when I spawn any machine. For example I just spawned Legacy and it came up with an IP address of 10.129.96.145 instead of 10.10.10.4

@huesos35 said:

Yes I am using that link and having this issue, I have put a support request but have not heard back. It happens when I spawn any machine. For example I just spawned Legacy and it came up with an IP address of 10.129.96.145 instead of 10.10.10.4

When you try the link I sent, where is it saying it has an IP address of 10.129.96.145?

When I hover by the green dot next to the machine and also when i click on the name of the machine and it goes to the profile page. Thanks for helping me out, i really appreciate it.

@huesos35 said:

When I hover by the green dot next to the machine and also when i click on the name of the machine and it goes to the profile page. Thanks for helping me out, i really appreciate it.

Do you get something different to this?

If so, I’ve never seen that so I dont how to help. I’ve only ever seen other IP address when the box has been spawned into Pwnbox or the release arena.

Ok - it might be down to you being VIP+, as this seems a likely way to ensure you are the only person accessing the box.

Type your comment> @TazWake said:

Ok - it might be down to you being VIP+, as this seems a likely way to ensure you are the only person accessing the box.

Same issue for me… I got 10.129.107.58 for Tenet box with OpenVPN. And I’m not able to launch Pwnbox, error Could not mount personal drive (case open)…

And I’m VIP+ too… I’m starting to regret it… :frowning:

@choupit0 said:

Same issue for me… I got 10.129.107.58 for Tenet box with OpenVPN. And I’m not able to launch Pwnbox, error Could not mount personal drive (case open)…

And I’m VIP+ too… I’m starting to regret it… :frowning:

In theory the IP address being 10.129.x.x shouldn’t be an issue you can just attack it as if it was 10.10.x.x. However, the pwnbox error is more significant. I hope they resolve it quickly!

I hope too… For the IP address, not sure:

root@HTB:~/HTB# ip route
10.13.38.0/24 via 10.14.14.1 dev tun0
10.14.14.0/23 dev tun0 proto kernel scope link src 10.14.14.18

Type your comment> @choupit0 said:

I hope too… For the IP address, not sure:

root@HTB:~/HTB# ip route
10.13.38.0/24 via 10.14.14.1 dev tun0
10.14.14.0/23 dev tun0 proto kernel scope link src 10.14.14.18

My bad… I didn’t use the good *.opvn file… so stupid…