I cant access Web Pages of the box

Hi Everyone. I am an VIP user whenever i connect with boxes and ping them all are fine.When i nmap and find out some webpages on port 80 and try to access that on browser it just dosent show at all.It loads loads and than problem loading page error is showen.The result is same when i try to find directories of that webpage and find some directories and try to access it the result it same.Please help me anyone

If that’s for more than one box, then with the limited I formation your provide, this sounds like a local thing.

You could try connecting by downloading a connection pack for another region and see if that worksor try the tcp/udp switch as described in the connection packs, but this kinda sounds to me like a local issue.

You sure you got no firewall anywhere? What OS are you using?

I am having this issue in multiple boxes. Yes i have tried switching different region box but issue is not resolved. I am using kali linux 2020.2

@AHKompany said:

I am having this issue in multiple boxes. Yes i have tried switching different region box but issue is not resolved. I am using kali linux 2020.2

I agree with @gnothiseauton in that it is hard to work this out from the information provided.

So if ping/nmap works, we can assume that the network connection is valid and the server is running.

That means the problem is almost certainly in your browser.

  1. Check if you can visit non HTB webpages in the browser
  2. Check if you have a proxy set up (for example, you’ve configured it to go via burp and burp is turned off)
  3. Check you don’t have some firewall or other security device seeing this traffic and thinking it is evil.
  4. Check your hosts file. Some pages wont respond to IP address, some need a hostname.
  5. If you are getting inconsistent error messages (for example “Page Not Found” vs “Problem Loading Page” etc), then the problem is more complex and the browser is probably broken. If this is the case, based on the information provided, the easiest thing might be to simply reinstall the OS…

Do you have the same problem when you run nikto or dirb/gobuster against the IP address?

1 Like

Ok so this is really weird i was frustrated that i wasn’t getting my nmap result and web pages although i was connected with the vpn.So i changed my internet connection and i got my nmap result and web pages .Can anyone thing what can be the cause of that? As my internal computer networks work fine and same HTB why i cant connect through my local internet provider at my home?

1 Like

So my solution to this problem
I did a new vm of kali 2020.3 version.
I didnt download any tool i just download the ovpn file and tried to access the machine.I failed to ping the machine even though on the 2020.1 version i was able to get the result.
So lucky my internet died and i start using my backup and lucky i decided to open the machine and start for scan.The scan was up and i was able to access the webpages. The thing i dont understand why i was not able to access it though my primary internet connection.Are they blocking or what? if anyone has any idea please do share

I’m having a similar issue. Also VIP
Using Pwnbox I can ping and nmap scan the target box, however I am unable to access the associated web server with Firefox. I can use curl to get the http headers though.

Firefox works on non HTB webpages. But for the target machine I get “We can’t connect to the server at…”

For me, it ended up being 2 VPN’s, One VPN on Vmware player and another VPN my Windows host. Since I’m working on a virtual box (VMWare for me), and using OpenVPN connection configurations from HTB, my personal host machine VPN is causing the pages not to load on my target boxes.

Let me reiterate:
So my Windows Host is using a VPN client it autoconnects whenever I start up the machine, while using Kali Linux on VMWare Player and connecting to HTBs OpenVPN client. If I turn off my Windows Host VPN, the HTB target machine pages load. Otherwise, I get the loading wheel of death. No errors! The page just never completes loading. My PoC was using BurpSuite in one of the challenges and the page returned the call, but the page never loaded so I just applied simple Firewalling concepts to my investigation. “Visiting the site made the trip, but not back to my machine… Maybe a port or protocol is being blocked by something…”

No I did not make any Firewall changes to test this theory. I just turned off some of the features that I added along the way while transitioning from the HTB Attackboxes to my own Kali VM Machine.

Turning off the host VPN allows the page to load and I can complete my challenges.

Hope this helps someone, if not for you.

[Edited]

2 Likes

Had the same problem, found a solution which worked for my setup.

I use a hybrid Internet connection (LTE+DSL, because the DSL only option is pretty slow here) which led to some problems, because my two connections are merged via DNS on the provider side. This commonly leads to some problems in various VPN configurations.

I had to disable the hybrid option for the VPN connection in my router’s settings.
If you need to create a similar exception rule in your setup, remember that the HTB VPN USES PORT 1337 instead of 1194.

Thanks to this thread for hinting me in the right direction, I hope this helps someone.

Tips to fix-
Check Your Connection (and Other Sites)
Browse a Cached Version of the Page.
Disable Add-Ons and Other Interfering Software.
Narrow Down the Problem.
Fix Your DNS.

Regards,
Rachel Gomez

dude ur awesome :wink:

I had the same issue but you need to write into the /etc/hosts file. <machine_ip> <website_url>
for example for the Busqueda it would be: 10.10.11.208 searcher.htb

3 Likes

THANK YOU, I kept re-downloading the VPN and troubleshooting my browser

1 Like

In case it is still an open question for someone, I struggled a lot with that until I accedently used my wireless wifi adapter and connected to my home network.

So for me when I open Kali VM on Virtual Box it can access internet through eth0, but I can only google stuff. Opening the hosted website on machine or making Network attacks is not possible, for that you need Wifi adapter.

So yeah connect to your home Network and everything should work

*if you’re running kali on VM and are not connected already x)

This worked perfectly, only took like 4 seconds to load the page after I turned my windows vpn off. Thanks again!

Add the host ip and host name to your /etc/hosts file

sudo vim hosts

append a line at the bottom of the file, for example:

10.10.11.242 devvortex.htb

This worked for me after hours of trying!