Help me with windows attack & defense PKI-ESC1

Connect to the Kali host first, then RDP to WS001 as ‘bob:Slavi123’ and practice the techniques shown in this section. What is the flag value located at \dc1\c$\scripts?

Hi, I’m stuck on this part and I can’t go on, I don’t understand how the things works. After creating the certificate cert.pem on the ws001 machine with certificate.exe they suggest to modify the file in a .pfx but it’s not explained how should I do it with the Kali, the documentation only shows a couple scripts to convert the file but I’m not understanding how should I pass the file from the ws001 to the Kali and back again once converted. Please help me :pray:

do smbclient from kali, just type smb, command is alredy prefilled. I stuck after transfering the file to kali, can1t convert it. If you can please let me know

1 Like

Save the certificate Just doing copy paste on a txt on the Kali, then do the command to convert, first this one “sed -i ‘s/\s\s+/\n/g’ cert.pem” and then this “openssl pkcs12 -in cert.pem -keyex -CSP “Microsoft Enhanced Cryptographic Provider v1.0” -export -out cert.pfx” , once you convert it, you can transfert the file in the other machine, hope will be helpful

1 Like

thank you, it worked

1 Like

Hello.

how can i RDP to WS001. i tried ping to WS001.eagle.local to know the ip and RDP to that adress but i failed. It says the trust between computers failed.

please help.

The ip of the ws001 should be the 172.16.18.25 if I remember…when you open the attack machine search in the start menu for “Remmina” and use it to connect via RDP the machine

thanks. i already solved. i asked because the conection was failing. HTB says to wait 10 minutes when conected to targed machine to load settings.

1 Like

hello, tried to use the

“sed -i ‘s/\s\s+/\n/g’ cert.pem” and then this “openssl pkcs12 -in cert.pem -keyex -CSP “Microsoft Enhanced Cryptographic Provider v1.0” -export -out cert.pfx”

however i got this error: No supported data to decode. Input type: PEM

what should be the format inside the cert.pem file?

hey @josemmm11 im still getting the error trust between computers failed. how did you solve these

contact HTB support and explain to them the error to get support.

Best regards

same here :melting_face:

Finally got it: the machine is just not stable, reload is untill the error stops appearing :smiling_face_with_tear:

Hi there, I got this error “could not read private key from -in file from cert.pem” Does anyone else have it? I’m really stuck in here :pray: