[Academy] NTFS vs. Share Permissions: Mount Error

Hello,

I am working on Windows Fundamentals and am stuck on the NTFS vs. Share Permissions module.

After disabling the public firewall in my Windows 10 target box, the next instruction is to create a mount point on the Desktop on our Pwnbox with the command:
sudo mount -t cifs -o username=htb-student,password=Academy_WinFun! //ipaddoftarget/"Company Data" /home/user/Desktop/

I replace ipaddoftarget with the Windows instance’s ip, Company Data is the name of the shared folder. I installed the CIFS utilities in case that was the issue.

The errors I encounter are :
Couldn't chdir to /home/user/Desktop: No such file or directory
I tried changing that part of the command to /Users/htb-student/Desktop (the path to the shared “Company Data folder” ) and get the same error.

I tried leaving the path off and using:
sudo mount -t cifs -o username=htb-student,password=Academy_WinFun! //ipaddoftarget/"Company Data"
and get the error
mountL //ip/Company DataL can't find in /etc/fstab

Any thoughts, suggestions, or hints are much appreciated! (:

Thank you

Hi, could you solve the problem? If yes, how did you do it?

/home/user/Desktop is the file location on the pwnbox where the mounting point is being created. replace user with your pwnbox username (htb-########)

thank you so much!

This may be a dumb question, but where do you get the pwnbox username? I’ve tried multiple things and I keep getting the error “mount: /home/user/Desktop/: mount point does not exist”

Such a situation may also arise due to one or more of the following reasons:

The Exchange database (.edb) you are trying to mount is either corrupt or inconsistent.
The server has little or no disk space to complete the database mount. Thus, it can’t store new logs or provide space for database expansion.
Missing or deleted transaction logs.
Dirty Shutdown.

Regards,
Rachel Gomez

1 Like

In my case it’s htb-ac-838315

I ran my command after figuring out that i had to use my pwnbox username and received this message. i’m confused, does that mean it’s running the mount or not?