Unable to migrate process (grandpa)

I dont if the problem is from my side or from box, but I need help. After getting meterpreter session using windows/iis/iis_webdav_scstoragepathfromurl when I try to migrate from current process to another process the box goes down?
meterpreter > migrate 1796
[*] Migrating from 2260 to 1796…
[-] Error running command migrate: Rex::TimeoutError Operation timed out.
meterpreter > ps
[-] Error running command ps: Rex::TimeoutError Operation timed out.
meterpreter > getuid
[-] Error running command getuid: Rex::TimeoutError Operation timed out.

After this I need to reset the box

Happens sometimes when it fails migrating process.
You don’t need to reset the box, only need to do a new meterpreter connection.

Type your comment> @novam said:

Hello, I have the same problem and I tried to migrate to each “interesting” processes but it fails with the same error :

[*] Migrating from 2260 to 1796...
[-] Error running command migrate: Rex::TimeoutError Operation timed out.

Does someone find a way to fully exploit these machines ? I get stuck because of that process migration which seems to be mandatory.


I kept trying did like 15 times and finally got lucky


I had exactly the same problem. I already had difficulty to exploit the first vuln… Always had an “Exploit successful but no session was created”. Must tried a lot of time. Same problem with the exploitation of tcp_ioctl… Never had the chance to have a session with ioctl but able to come back to my meterpreter and using getsystem to escalade as System NT :slight_smile: