Tier 0 help needed please. Not dumb I'm just missing something

I used to be able to get the tun0 data after ifconfig command. Then I noticed I was getting tun1, tun2, etc. I deleted them. Now no matter what I do I can’t get tun0 after ifconfig. I’ve asked chatGPT and tried dozens of things from the internet and forums.

I need a human to help me please! I swear I’m not dumb but getting stuck on the first box is very discouraging. :frowning:

Try maybe sudo systemctl restart NetworkManager (or .. NetworkManager restart, I always get the order wrong). Or just reboot. In any case, what does it matter if you get tun0 or tun1 ?
Did you start multiple instances of OpenVPN ?

Looks like you definitely have multiple VPN session open, try restarting the OS or try

systemctl restart NetworkManager

Thank you both! I tried that and it still giving me this:

when I’m trying to get this:

looks normal to me, what’s the issue? tun0 has your HTB IP

The walkthrough that is attached to that box says multiple tun instances (which I had) would cause it to not work. Now I don’t know how to get back to where I was. I even started over. Then I put a virtual machine on my PC (first did all this on my Macbook) and tried it there and still couldn’t generate any tun data. It looks like the Openvpn opens and run then exits immediately and I can’t find the config files. I really tried on my own (and asking chatGPT with code snippets) and I can’t believe I got this stuck on the baby box.

Thats the screenshot from a tutorial online. The first one is me without it. I can’t seem to generate it no matter what I do…

try logout, clear cookies and caches and restart the computer

ok so you are using Open VPN I guess

awesome idea! I feel dumb. Thank you, will try now.

yes sir

ok have you ever connected any other vpn via config file from the network manager? you can also try sudo openvpn openvpn.config to create a tun0 connection as well

I get this error
┌──(meow㉿kali)-[~/Downloads] └─$ sudo openvpn openvpn.config Options error: In [CMD-LINE]:1: Error opening configuration file: openvpn.config Use --help for more information.

and no I’ve never connected to any other vpn config file. I literally learned how to do the VM just for this. I appreciate you helping me. Sorry I with I knew more.

you need to download the openvpn.config file from Hack the box, depending on which room room you are using, such as Machines, Fortress etc… and then you can just use sudo openvpn youropenvpnfile.config

if you click on connect to vpn you can see Machines, Starting Point, etc… Check the room that you are using, is it inside the Machine or starting point, and then download the config file

by the way if you are totally new to technical stuff, especially hacking try using TryHackMe rather than Hack the box, you will get the fundamental training.
As per John Hammond, Try hack me is for people who want to learn something new, without banging their head against a wall, and HTB is for people who want to spice things up or try to improve their skills.

1 Like

I really appreciate that! I’m great with Adobe products and teaching myself JavaScript, etc but this has really thrown me! Thank you very much for you time and consideration. Wish I could help you!

1 Like