Starting point - Archetype - reverse shell problem

Hi all, please help me with this. I am trying to complete the archetype machine, and I am able to get a connection with the reverse shell - my server shows that the .ps1 file is successfully downloaded, and the listener shows that it has a connection.

The problem is that if I type anything after this, I just get a # sign and no output. So its like:

whoami just for example, this could be any command

After this, it does not matter what I write, only a # will appear in the next line. What could I do wrong?

I tried:

  • checked if there is any blocked traffic on my virtual kali.
  • tried to disable my firewall on the host machine
  • tried to add rule to my firewall to allow traffic on ports 80 and 443
  • tried to add rule to my firewall to allow traffic on all the ports
  • tried to run all the commands as root

I am using a Kali Linux running as virtual machine (VirtualBox), my host machine is Win10 x64.

Update: solved. I dont know what solved it but solved.

The last " was missing

Having issues running the script as well. I get malicious script errors as well as an incorrect ampersand error on the reverse shell script inlcuded in walkthrough

I’m now having this identical issue of # with no output. Have any ideas what you did differently?