Problems applying exploits to Legacy machine

Hello! I’ve just joined the site and decided to start with Legacy as it seemed fairly easy. I’ve ran nmap and managed to found the machine to be running Windows XP SP+2. Through some walkthroughs I’ve watched I noticed everyone seems to be getting Windows XP SP3. I tried running Eternal blue and ms08_067_netapi however they do not work. There’s a specific error I’m getting from ms08_067 and it look like this: s - Album on Imgur

I’ve checked LHOST and my vpn connection multiple times and I’m pretty much out of ideas. The msf version that I’m using is 5. I’d appreciate any help that you guys could give me. Thanks !

I’ve not tried any exploits or msfconsole yet…

But I’m definitely connected, ping works, nmap works as intended. Considering the SMB ports are open, I try to enumerate with enum4linux and smbclient… both time out.

Considering RDP is open, I try to connect…connection refused/timedout.

Not sure what the issue(s) is, but it seems rather common for this box after researching thru the forums - with no clear solution or answers.