Problem with exploit "Legacy" and "Lame"

I just bought my VIP and tried the retired machines. Firstly, I was trying to own the “Legacy” machine, I did everything like in the walkthrough but I’ve got an error that looks like this:
[*] Exploit completed, but no session was created.
Since I saw that this machine seems to have problems generally, I tried the “Lame” machine. There was the same error…
Pls, help if you know what could be wrong.

You are using metasploit framework right?

This problem just means that the exploit runned but couldn’t get a shell. I suggest u to try githubs exploits instead of using metasploit.

Yeah, I’m using Metasploit. I don’t know why I didn’t mention that :grimacing: I will try GitHub and let you know what happens, but I have a question. Is it means, that I will have to always use GitHub instead of Metasploit?

This error usually happens if you forgot to set the LHOST value.

You can set LHOST using the follow command

set LHOST 10.10.X.X

set LHOST tun0

■■■ It worked! Thank you alot!

Nice. I would also suggest you follow the advice above. It is usually advisable to try to also exploit a system without metasploit. That helps you to understand the scripts you are running and how to modify them to make them work for you.

1 Like