Official Line Discussion

Official discussion thread for Line. Please do not post any spoilers or big hints.

I’m curious about this being marked as ‘easy’ ?!
I can’t seem to get beyond possibly identifying the printer queue name using an LPD script from P**T.

I’ve read through to no avail, any clues to what I’ve overlooked?

1 Like

Whelp, I was on the right line, the syntax was just very finicky. pfft.

Same problem. Stuck with the P**T tools. Tried to run LPD commands directly against the port, with no success. Any ideas? I think I’m starting to overthink the problem…

You’re very much on the right lines, look closely at the example usage of **** and try not to get shellshocked overthinking things.

Having tons of trouble with this one. I can’t seem to get the syntax right. Some help please?

Could you please help me out with the syntax? This is becoming ridiculous. I’ve spent many hours messing with the **** script to no avail. For an easy challenge, this is giving me way too much trouble. I’ve asked around on Discord too and nobody seems to be able to help.

I’ve tried all the examples in the **** README. Changed the syntax slightly, but no success. I also tried all the examples found at GitHub - MrCl0wnLab/ShellShockHunter: It's a simple tool for test vulnerability shellshock (see Source file ( Exploits)), no success.

It seems that the **** script doesn’t return any output. Or I am using the wrong syntax.

No idea…

Anybody knows what’s wrong?


PM me

1 Like

Any chance I could PM you for a nudge too? Been stuck on your last hint for a few days.

1 Like

I’m struggling with P**T script too.
Also tried kinds of quotes and escaping characters to my commands, nothing responsed.

1 Like

(post deleted by author)

That github repo helped me a lot, thanks @kruemel1! I found the missing piece there. With that, the **** script and ngrok I managed get the job done. If anyone gets stuck, feel free to dm me.


Some hint pls? I cannot even figure out the attack path, since I can’t ping my pc, being out of the VPN…

Dm me

Just DM you.

I just doubt that this challenge is easy. I tried everything in lpd****.py from PRET.

Went further and tried all shellshock payloads and tried to send an input file loaded with shell with *** but with no luck.

Any hints?

I’m pretty confused on this challenge, and am unsure if I’m overthinking it. Using the aforementioned tools, I was able to get full root access to the box. I downloaded an entire copy of the server script so I know all possible functionality, and I still haven’t been able to solve the challenge. Is there some sort of Machine-like post-exploitation phase, or at this point have I overshot the original goal? Looking for some guidance, thanks!

You need to use eth0 ip not tun0 IP.

the challange is hosted on the actual internet, not the VPN, that is why.


Anyone willing to help on this?
Tried the ***** script with some shellshock examples but to try a reverse shell but nothing works