Official Codify Discussion

Official discussion thread for Codify. Please do not post any spoilers or big hints.

Good luck everyone!

Happy hunting

foothold was ez…

Agreed. Literally my first hit in Google. Definitely nice to get one of those every once in a while.

Priv esc tips?

Look around. You will see.

I see what I need to misuse, but looking inside, can’t figure out how :smiley: Tried a couple of things, not working, hopefully it’s not a red herring

root hint:

look carefully, there is a pretty WILD way to do something

1 Like

Hello can someone give me a hint on what type of payload to use to have a reverse shell please ? i’ve tried many thing but getting the “Command failed:” error.

Thank you !

im in the same boat, all of the reverse shells Ive used dont seem to work.

Can i get any hints for root ? Im stuck

help me step-bro, im stuck on root


Onto the next one!

Please wait until the box has been live for 24 hours before DM’ing for hints. After that, feel free.

1 Like

Hi !! can someone give me a hint , I already have acces to the machine, now I need to become other user -w-

Finally got it but it seems that the other players have helped me to be root by letting some evidences. I got the password but not in the regular way i think (or maybe yes)

1 Like

Am I meant to be able to access port 80 and 3000? I have reloaded the box about 10 times and same error each time.
I’ve captured in wireshark and consistently get “[tcp previous segment not capture] continuation” after the handshake and get request. Do I just have to wait for it to be less busy?
EDIT - still not sure what the issue was exactly, but I switched my vpn to UDP and it worked.

User access was a breeze but the root part had its quirks. Getting to user involved a bit of persistence and a sprinkle of ingenuity. However, ascending to root required a deeper dive, a few creative twists, and a pinch of randomness. It’s all about mastering the art of thinking differently. #Happy_Hacking :pirate_flag:

1 Like

I found the wildcard trick for root, but I don’t know how I’m supposed to use that to actually get the password, any tips?

I got the reverse shell, but still looking for ways to switch user or get root…

For those having issues with the reverse shell for initial access. I was able to get one working from here: