ODAT installation

I’m trying to install Oracle-Tools-setup.sh as detailed in the Oracle TNS section of the Footprinting module in the HTB academy. I ran the given bash script that is added to the section:


sudo apt-get install libaio1 python3-dev alien python3-pip -y
git clone https://github.com/quentinhardy/odat.git
cd odat/
git submodule init
sudo submodule update
sudo apt install oracle-instantclient-basic oracle-instantclient-devel oracle-instantclient-sqlplus -y
pip3 install cx_Oracle
sudo apt-get install python3-scapy -y
sudo pip3 install colorlog termcolor pycryptodome passlib python-libnmap
sudo pip3 install argcomplete && sudo activate-global-python-argcomplete

Everything seems to have gone over smoothly except for the last sudo command. I keep getting the following error: sudo: activate-global-python-argcomplete: command not found

I also tried to install ODAT by doing sudo apt install odat. I made sure all the dependencies it needed were installed but I get the following error E: Unable to locate package odat

Any help with the installation would be much appreciated!!

you need to go into the odat folder that you downloaded with the apt install and locate the odat.py file. Once located, use ./odat.py -h make sure it is working properly.

I posted in another post because i didnt see this but I’m having problems running on Kali linux(not live) pls check out my post here Footprinting: Oracle TNS - Cannot Install SqlPlus i dont know how to move the post and need help im stuck . i had installations errors, odat.py giving errors, wont complete what it needs to do seems pretty buggy unless im missing something