Footprinting: Oracle TNS - Cannot Install SqlPlus

Hello All,

I’m working through the Oracle TNS section of the Footprinting module. I’m getting stuck on the commands were are supposed to execute to get odat.py and SqlPlus working.

When I attempt to install oracle-instantclient-devel and oracle-instantclient-sqlplus, I am met with the following errors:

I’ll also get the below errors:
E: Unable to locate package oracle-instantclient-devel
E: Unable to locate package oracle-instantclient-sqlplus

I attempted a sudo apt-get update and sudo apt-get update --fix-missing, it did not resolve the issue.

Does anyone know a workaround for this?

I found the issue. It looks like the .deb packages were updated from …parrot1_amd64.deb to …parrot2_amd64.deb. I manually downloaded them from: Index of /parrot/pool/non-free/o/ and installed via dkpg.

I tried this solution. Instant client basic refuses to install due to libc dependency.

"The following packages have unmet dependencies:
oracle-instantclient-basic: Depends: libc6 (>= 2.34) but 2.31-13+debllu7 is installed
E: Unmet dependencies. Try “apt …fix-broken install’ with no packages (or specify a solution).”

Updating libc6 does not work aaaand basic has to be installed in order to install dev and sqlplus. Update, upgrade, --fix-missing - nothing does the job. You really managed to bypass this? How?

I contacted the customer service and asked them to fix the issue. ■■■■’s broken and I lack the skills to fix it.

@deepee After running

sudo apt install oracle-instantclient-basic oracle-instantclient-devel oracle-instantclient-sqlplus -y

then you run

wget https://deb.parrot.sh/parrot/pool/non-free/o/oracle-instantclient-devel/oracle-instantclient-devel_19.6.0.0.0-0parrot2_amd64.deb
sudo dpkg -i oracle-instantclient-devel_19.6.0.0.0-0parrot2_amd64.deb

wget https://deb.parrot.sh/parrot/pool/non-free/o/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus_19.6.0.0.0-0parrot2_amd64.deb
–2024-02-07 02:46:41–
sudo dpkg -i oracle-instantclient-sqlplus_19.6.0.0.0-0parrot2_amd64.deb

…and it should install them correctly

1 Like

I created a script to install SQLPLUS correctly

wget https://download.oracle.com/otn_software/linux/instantclient/214000/instantclient-basic-linux.x64-21.4.0.0.0dbru.zip && wget https://download.oracle.com/otn_software/linux/instantclient/214000/instantclient-sqlplus-linux.x64-21.4.0.0.0dbru.zip && sudo mkdir -p /opt/oracle && sudo unzip -d /opt/oracle instantclient-basic-linux.x64-21.4.0.0.0dbru.zip && sudo unzip -d /opt/oracle instantclient-sqlplus-linux.x64-21.4.0.0.0dbru.zip && cd /opt/oracle/instantclient_21_4 && find . -type f | sort && export LD_LIBRARY_PATH=/opt/oracle/instantclient_21_4:$LD_LIBRARY_PATH && export PATH=$LD_LIBRARY_PATH:$PATH && source ~/.bashrc && sqlplus -V

It was based on https://www.geeksforgeeks.org/how-to-install-sqlplus-on-linux/

3 Likes

im getting the following errors while trying to install everything on Oracle tns footprinting page. Odat.py comes with Kali linux but i tought the version was buggy or something because when i type ```
./odat.py all -s 10.129.whatever.whatever


now it works fine but when tring to install using their script here is the outcome. Was anyone else running into this issue on Kali 2024?

well i take that back more problems with that python script odat.py here is the latest. Whats wrong with this?

Thank you so much !

Thanks a lot.