Nmap lab IDS/IPS evasion issue

I’m stuck on a lab for Nmap’s Firewall and IDS/IPS Evasion, any help would be appreciated.
I’m trying to spoof the scan’s source IP address, just as it’s discussed in the module, and I keep getting the nmap error “failed to determine route”

Here is my scan and result:

$ sudo nmap 10.129.208.213 -n -Pn -O -S 10.129.208.200 -e tun0
Starting Nmap 7.92 ( https://nmap.org ) at 2022-03-24 08:12 GMT
setup_target: failed to determine route to 10.129.208.213
WARNING: No targets were specified, so 0 hosts scanned.
Nmap done: 0 IP addresses (0 hosts up) scanned in 0.21 seconds

I’m guessing the issue has to do with the interface I’ve specified with the -e flag, however I’ve tried all available interfaces (tun0, eth0, eth1) and all produce the same result. What am I doing wrong? Thanks for any help.

Note: I can scan the address 10.129.208.213 just fine, but whenever I use the -S to spoof I get this error

1 Like

No ideas why I cannot spoof the source IP address?

Which is the lab that you stuck (easy, medium or hard)?
I don’t remember that I used a manual spoof address (like with “-S” flag) to solve those nmap labs. Try only use a decoy scan with random ip address.

It’s the easy lab.
I think I was going about it the wrong way, but the -D flag definitely works as it should, thanks.
For some reason the -S flag doesn’t work in those lab virtual machines