Linux Privilege Escalation - Skills Assessment - Final Flag

I am struggling with the privilege escalation for the final flag. I have a shell, but the GTFObins escalation route files with !/bin/sh not found. I am told this is because I don’t have a stable shell, but using msfvenom (the shell is less interactive) that the metasploit route, but both shells yield the same result.

I read in my searching that this machine doesn’t behalf as expected and another exploit is required, but through LinEnum and LinPeas I am not seeing what that would be. Appreciate a nudge.


RESOLVED - the usual path that many had taken before did not work for me. Despite stabilizing the shell the best that I could, the GTFOBin escalation never worked. I ended up finding another vulnerability on the box that I used to escalation privileges as root. Enumeration was my friend in this one!

Hi ! Im like you not able to make the GTFObins escalation with !/bin/sh although i got a full tty … Can you point some tip for the other escalation privilages that you found im super stuck.