Legacy, metasploit "Cannot reliably check exploitability"

Currently working through the Legacy box. Everything checks out until I try to run the ms08-067 exploit. When I check prior to running the exploit, metasploit says “Unable to reliably check exploit vulnerability”. When i run the exploit, this is the output.

msf5 exploit(windows/smb/ms08_067_netapi) > run

[*] Started reverse TCP handler on
[-] - Exploit failed [unreachable]: Rex::ConnectionTimeout The connection timed out (

I am running on a kali VM on windows 10. I am running through a vpn from my work network and connecting to the htb vpn. Under access, it looks like everything is connected, and I was able to scan the machine just fine no issues. Not sure what the potential problems might be. Thanks for anyone willing to lend a hand.

Nevermind. After rescanning ports, it looked like a firewall was up? I reset the machine and it worked fine. I don’t know what was the issue. Maybe someone snuck on and patched the machine? haha.