HTB Academy : Cybersecurity Training Nibbles - Privilege Escalation

Hello everyone! I ran into a problem. I’ve done the work in various ways, but I can’t get root rights in any way. In the end, I do everything according to the instructions, but when changing the and running the script, I can’t get the shell root. Please tell me what I’m doing wrong, how do I fix the result?
p.s. I attach screenshots.

thank you for your help

1 Like

Hey! It looks like you probably forgot to put in your IP address when you pasted the reverse shell into the file. Unless your tun0 IP is really

Run any of these on the command line ip addr show tun0, ip a, or ifconfig to find your IP. Everything else looks fine.


Hi, I confirm what it says @onthesauce you are using the default ip set in the exercise. you have to use your local ip tun0.


I used ip a, as I usually did, replaced in , but the result still hasn’t changed :frowning:
The problem is probably something else. I will attach a screenshot showing the problem.

I would be very grateful if you can give a hint.

Greetings to you!
I changed the ip, as onthesauce said, but nothing came out (
I attached screenshots again, maybe you know how to solve the problem?

I try Googling and searching on the forum, but to no avail. It’s a shame, but it looks like I’m the only one stuck on this topic.

Are you catching the reverse shell with nc? It shouldn’t escalate in that window.



nc -lvnp in your machine

remember to update your ip inside (when you disconnect and reconnect it will change)

1 Like

I run the script on a hacked machine, and then run nс at a separate terminal. Must it done in a different way? At the first stage of the attack, I did it this way and everything worked out. The new terminal window does not launch nсt on the attacked machine, right?

in order:
your terminal : nc -lvnp <port write in, i read 8443>
terminal target system: launch

1 Like