How to find FQDN of the nameserver for the inlanefreight.htb" domain

I am stuck with quesiton . I add the machine IP in /etc/hosts " IP inlanefreight.htb" when i am doing nsloookup i am getting error "** server can’t find 82.202.129.10.in-addr.arpa: NXDOMAIN " . What’s the reason ?

Can you show the full nslookup command you used? also is this on windows or linux?

1 Like

I think the reason for this error is that the DNS record for “inlanefreight.htb” only exists in a particular nameserver. So consider using command like: dig @nameserver_ip inlanefreight.htb

3 Likes

Let suppose this is the IP 10.129.184.1 and the domain is inlanefreight.htb. I add this in the /etc/hosts file " 10.129.184.1 inlanefreight.htb" . Now the question this find FQDN of this inlanefreight.htb. so I used the command ‘nslookup 10.129.184.1’ and i am getting this error Server: 192.168.1.1
Address: 192.168.1.1#53

** server can’t find 82.202.129.10.in-addr.arpa: NXDOMAIN

I used mac

I’m stuck as well. I’ve tried it with and without adding the ip/domain to /etc/hosts. It would be helpful if HTB displayed how many characters and/or in what format they are looking for like THM does. I’ve tried nslookup, dig, wafw00f, and even nmap, none of the results are the correct answer (even with a “.” at the end and/or the full path name of “https://www.” and/or any variation thereof with/without the full path name):

a. root . servers . net

nstld . verisign-grs . com

root . inlanefreight . htb

inlanefreight . htb

x. x .x .x. in-addr .arpa

The only good outcome of trying to answer this question was stumbling upon Flag No. 1 for the next section, question 1. I’m not sure if I’m over thinking something, glossing over something obvious to others, entering the correct answer but not adding some required character, or that I’m totally lost. I hope this information helps others get further than I did, and if so, please advise without giving the answer away.

how i did this task is " nslookup -query=NS inlanefreight. htb $IP " ip your spawn machine ip

Got it, thank you! I’ll have to study nslookup a bit more…

1 Like

Cant find last FQDN of the host where the last octet ends with “x.x.x.203”
Any hint? Hint " Remember that different wordlists do not always have the same entries." dosent work. I tryed many DNS wordllist :frowning:

dig axfr/any/ns [internal.]inlanefreight.htb @IP OR dnsenum, dosnt help with that

sk7698277’s nslookup command above worked for me. As far as the connection timed out, it seems that the servers are offline. Try respawning the target machine. It’s been awhile since I did this one. Which module is this for?