Explanation Please

The question:
Which kernel version is installed on the system? (Format:1.22.3)
The correct answer is: 4.15.0
I got that answer with the help of YouTube video because when I tried the ways of finding this information I was found something completely different.


I have tried to reset the VM but I still keep getting 5.10.0

When things like this happen how do some of the more experienced users move forward?

I also tried to use the cmd neofetch and it gave me the same results.


Unless the system is compromised there is not reason not to believe uname -r response.

You could also check /proc/version, or, if you are very suspicious, given that the kernel comes with the distro and its not compiled by you, you can check the md5sum of the kernel file and compare it with the one included in the distro package.

It could also be something tampering with the uname syscall, check /etc/ld.so.preload just it case its not empty.

Thanks! I was stuck on this for about a week +
What was the name of the video you watch?

Thank you!