Evil-WinRM Seemingly Novel Problem

I’m having a hard time getting Evil-WinRM to run on my Kali box. I’ve tried just about everything I can think of from reinstalling evil-winrm, reinstalling all dependencies, installing from github, installing from bundle, and all using both apt and gem. No matter what I do I simply cannot get free of this error message, and hours of googling have given me absolutely no headway into what is the problem or how to fix it.

This only happens when making a connection. All dependencies listed in the github are installed.

$ evil-winrm -i xxx.xxx.xxx.xxx -u xxxxxx -p xxxxxx

Evil-WinRM shell v3.3

/var/lib/gems/3.0.0/gems/evil-winrm-3.3/lib/evil-winrm.rb:123:in `completion_check': undefined method `quoting_detection_proc' for Reline:Module (NoMethodError)
	from /var/lib/gems/3.0.0/gems/evil-winrm-3.3/lib/evil-winrm.rb:473:in `main'
	from /var/lib/gems/3.0.0/gems/evil-winrm-3.3/lib/evil-winrm.rb:967:in `<top (required)>'
	from <internal:/usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb>:85:in `require'
	from <internal:/usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb>:85:in `require'
	from /var/lib/gems/3.0.0/gems/evil-winrm-3.3/bin/evil-winrm:3:in `<top (required)>'
	from /usr/local/bin/evil-winrm:23:in `load'
	from /usr/local/bin/evil-winrm:23:in `<main>'

Has anyone ever encountered this before and if so, how did you resolve it?

1 Like

Unistall it all and start over. Install from a source and ifnthatndoesnt work, completwly uninstall it and install from another source.

Samebthing happened to me. Also be sure to do updates as you go along.

Yeah I tried that about a half dozen times and no dice.

Either way I managed to fix it. Line 123 was the only instance of calling quoting_detection_proc so I just deleted it. Worked like a charm and I’m kicking myself for wasting so much time when I thought to try that from the start and just didn’t.

1 Like

getting the same thing in Windows. commented out that line does indeed work, cheers

Interesting. I actually get a similar warning, but it does run. My warning actually comes with a URL as well, which points to a line in the README on the github:

Warning: Remote path completions is disabled due to ruby limitation: quoting_detection_proc() function is unimplemented on this machine

Data: For more information, check Evil-WinRM Github: https://github.com/Hackplayers/evil-winrm#Remote-path-completion

Which then points to this on the github:

Remote path completion

This feature could be not available depending of the ruby you are using. It must be compiled with readline support. Otherwise, this feature will not work (a warning will be shown).

Hi,
Thanks for publishing this issue.
It should already be fixed on the dev branch of evil-winrm.
The problem was the firing of different type of exception on windows (where ruby is not compiled with readline).
Right now we have a problem with reline and tab completion when there are quotes. Quotes are needed to resolve correctly paths containing spaces and other word break characters.
When the reline behavior is fixed we’ll be in a good position to port the implementation using reline and easing the optional, non main, feature for remote path completion (tab).

:relaxed: