Xfreerdp is disconnecting a lot from the windows target machine

Hi all,

I just noticed that everytime I use RDP to connect to a windows machine, regardless if am launching the command from my laptop through vpn or Pwnbox, that I am having a LOT of trouble connecting. Sometimes I need 5 to 6 times in a row, and when I succeed, I just get disconnected.

This is getting very annoying as Im wasting a lot of time just having access to the machine rather than playing with it.

this is typically what you can enconter while hacking.
nothings ever works the way you want it to.


I get that but this is undoable. You cant even stay more than seconds before disconnecting.

then there is probably another way of doing it?
have you tried winrm, smb, that sort of things? or are you supposed to really use xfreerdp?


Have you tried with Remina?

1 Like

I didnt no, will give it at try to see! Thanks for the tip

Yes in some cases you need a gui, but I spec the whole day battling. Guess the network was saturated