Xfreerdp fails to install

Hello fam,
When I try to install Xfreerdp on my Parrot machine i got this error message:
┌─[user@parrot]─[~]
└──╼ $sudo apt-get install freerdp2-x11
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
freerdp2-x11 : Depends: libfreerdp-client2-2 (= 2.3.0+dfsg1-2+deb11u1) but 2.6.1+dfsg1-3~bpo11+1 is to be installed
E: Unable to correct problems, you have held broken packages.

Anyone can help please?
Thanks in advence

I ended up installing aptitude, then sudo aptitude install freerdp2-x11. From there it may prompt you and tell you the dependencies are out of date, if it does, choose no. The second one to pop up I selected yes to downgrade the dependencies to the correct version.