Why isn't the .exe I need downloaded from github?

I’m embarrassed to ask but I can’t seem to figure out how to get JuicyPotato.exe…I downloaded it from: GitHub - ohpe/juicy-potato: A sugared version of RottenPotatoNG, with a bit of juice, i.e. another Loc

But JuicyPotato.exe isn’t there so I assume I need to compile it or something but I’m too much of a noob to know how to do that. From what I read I need to use visual studios to convert the JuicyPotato.sln to JuicyPotato.exe but I’m on Kali so I’m downloading vmware rn so I can get on a windows vm to do that.

In the meantime I’m wondering if there is a way to get the exe without using windows/visual studios? Why doesn’t JuicyPotato.exe just come with the rest of the files I downloaded?? I swear I’ve downloaded exe’s directly from github before so what makes this one different???

Have you tried Releases · ohpe/juicy-potato · GitHub

I did try that before but I just clicked on the exe then clicked save but it saved it as an empty file. I just tried it again by using wget and it worked! Thanks for helping me out again!!

the .exe will be blocked by default when you download (firefox will see it as a threat)
Just right click and allow the download.
Tested on Kali

Ah gotcha, thanks. I just realized too if I click the downloads arrow on the top right of firefox it does say “this file contains a virus”.

I’m also in the process of downloading Watson and it seems like the exe can only be compiled from the sln file in Visual Studios. So I guess I’m still wondering why we have to go through all this trouble (not to sound lazy I’m just curious haha)…why doesn’t the author put the compiled exe on github? Is it because that would be too much work to do that every time there is a minor change made to the source code?? It looks like Watson may need the .NET version of the target machine before it is compiled so that makes sense for Watson at least. I just don’t get why JuicyPotato.exe wasn’t on the main guthub page.