Trying to learn to edit files but nano wont save because I am not in sudoers file

I attempted to follow the instructions to edit files in nano. If i just type nano notes.txt it won’t let me save the file (permission denied) , if I type in sudo nano notes.txt its asking for a password , but the HTB-student password wont give me sudo privileges?

Never mind. I used touch to create the file notes.txt, then I went into nano and it worked just fine. Is this the normal way an unprivileged user would do this or is there another way?

its normal, just dont use sudo, if not in sudoers. nano filename.extension

I tried that first but I only got “permission denied”

maybe you don’t have write permission in that particular folder, try writing to /tmp

I believe I am in the same exercise - I go to use the ^W function and it closes the window. This is all new to me so I’m just wondering if I am doing something wrong.

Also, it won’t write the file to the machine. Am I in the wrong place/directory?!?